summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2023-10-10 12:34:29 -0400
committerChris Severance2023-10-10 12:34:29 -0400
commitb3e477595dc575b8ca6df903593e717c4b5f6a5b (patch)
tree52d64e17a5ea634098ea26ff4cde9745116f95fc
parent5ccc4591c972b20d64aad67a0a16f2e5d06723f5 (diff)
downloadaur-b3e477595dc575b8ca6df903593e717c4b5f6a5b.tar.gz
autu: Update to 1.14.1.r0.g83bb793-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fed9774c1b1f..71f85f98d388 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = evdi-git
pkgdesc = kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video
- pkgver = 1.13.0.r0.gfe857b5
+ pkgver = 1.14.1.r0.g83bb793
pkgrel = 1
url = https://github.com/DisplayLink/evdi
arch = i686
@@ -10,7 +10,7 @@ pkgbase = evdi-git
makedepends = libdrm
makedepends = linux-headers
depends = dkms
- provides = evdi=1.13.0
+ provides = evdi=1.14.1
conflicts = evdi
source = git+https://github.com/DisplayLink/evdi#branch=devel
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 60f3ef057e92..ecd8481643b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Tested with Kernel 4.16, Dell D3000 SuperSpeed USB 3.0 Docking Station, 17e9:4318 DisplayLink
pkgname='evdi-git'
-pkgver=1.13.0.r0.gfe857b5
+pkgver=1.14.1.r0.g83bb793
_pkgver="${pkgver%%.r*}"
pkgrel=1
pkgdesc='kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video'
@@ -47,38 +47,42 @@ prepare() {
fi
done
- # Fix build for kernel 5.4
- #sed -E -e 's:SUBDIRS=([^ ]+) :M=\1 &:g' -i 'module/Makefile'
-
- sed -e 's:-Werror::g' -i 'Makefile'
+ #sed -e 's:-Werror::g' -i 'Makefile'
}
build() {
cd "${_srcdir}"
- # DKMS builds are hard to debug. We can build it here to debug the errors.
- if :; then
- # We only need to build the library in this step, dmks will build the module
- cd 'library'
- fi
CFLAGS="${CFLAGS/-fno-plt/}"
- make
+ CFLAGS="${CFLAGS/-fexceptions/}"
+ # DKMS builds are hard to debug. We can build it here to debug the errors.
+ #make -j1 -C 'module'
+ make -j1 -C 'library'
}
package() {
cd "${_srcdir}"
- install -Dpm755 "library/lib${pkgname%-git}.so"* -t "${pkgdir}/usr/lib/"
+ make -C 'library' -j1 install DESTDIR="${pkgdir}" PREFIX='/usr'
if ! :; then
pushd "${pkgdir}/usr/lib/" > /dev/null
+ local _libase
local _libs=(*.so.*)
- if [ "${#_libs[@]}" -ne 1 ]; then
- echo "Too many libs"
+ if [ "${#_libs[@]}" -eq 2 ]; then
+ _libs="${_libs[1]}"
+ for _libase in *.so*; do
+ if [ "${_libase}" != "${_libs}" ]; then
+ ln -sf "${_libs}" "${_libase}"
+ fi
+ done
+ elif [ "${#_libs[@]}" -eq 1 ]; then
+ _libs="${_libs[0]}"
+ _libase="${_libs%.so*}.so"
+ ln -sf "${_libs}" "${_libase}"
+ ln -sf "${_libs}" "${_libase}.0" # bad soname
+ else
+ echo 'Unhandled libs'
false
fi
- _libs="${_libs[0]}"
- local _libase="${_libs%.so*}.so"
- ln -sf "${_libs}" "${_libase}"
- ln -sf "${_libs}" "${_libase}.0" # bad soname
popd > /dev/null
fi