summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2021-04-12 13:21:45 -0400
committerChris Severance2021-04-12 13:21:45 -0400
commitc5f139e3dae4905ff84a1542e64a8ae4cb6897b3 (patch)
treebfacab40e149e64f8f63de606796298287fe89a4
parent4fc1465bc702c26d31d98b30590091ceba5700c8 (diff)
downloadaur-c5f139e3dae4905ff84a1542e64a8ae4cb6897b3.tar.gz
autu: Update to 1.9.1.r4.gb0b3d13-1 cleanup
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
-rw-r--r--evdi-git.Changelog12
-rw-r--r--evdi-git.install21
-rw-r--r--relro.patch11
5 files changed, 9 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24917e342a42..a09327d605d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
pkgbase = evdi-git
- pkgdesc = kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video git version.
+ pkgdesc = kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video
pkgver = 1.9.1.r4.gb0b3d13
pkgrel = 1
url = https://github.com/DisplayLink/evdi
- install = evdi-git.install
- changelog = evdi-git.Changelog
arch = i686
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index ff5510643041..3b424df3a9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,11 @@
# Tested with Kernel 4.16, Dell D3000 SuperSpeed USB 3.0 Docking Station, 17e9:4318 DisplayLink
-set -u
pkgname='evdi-git'
pkgver=1.9.1.r4.gb0b3d13
_pkgver="${pkgver%%.r*}"
pkgrel=1
pkgdesc='kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video'
-pkgdesc+=' git version.'
arch=('i686' 'x86_64')
url='https://github.com/DisplayLink/evdi'
license=('GPL')
@@ -18,20 +16,15 @@ makedepends=('git' 'libdrm')
makedepends+=('linux-headers')
provides=("evdi=${_pkgver}")
conflicts=('evdi')
-install="${pkgname}.install"
-changelog="${pkgname}.Changelog"
_srcdir="${pkgname%-git}"
source=(
'git+https://github.com/DisplayLink/evdi'
- #'https://crazy.dev.frugalware.org/evdi-all-in-one-fixes.patch'
- #'relro.patch'
)
source[0]+='#branch=devel'
md5sums=('SKIP')
sha256sums=('SKIP')
pkgver() {
- set -u
cd "${_srcdir}"
local _modver _rev
#_modver="$(awk -F '=' '/MODVER=/ {print $2}' module/Makefile)"
@@ -41,17 +34,15 @@ pkgver() {
else
printf '%s.r%s\n' "${_modver}" "${_rev##*.r}"
fi
- set +u
}
prepare() {
- set -u
cd "${_srcdir}"
local _src
for _src in "${source[@]%%::*}"; do
_src="${_src##*/}"
if [[ "${_src}" = *.patch ]]; then
- set +u; msg2 "Patch ${_src}"; set -u
+ msg2 "Patch ${_src}"
patch -Np1 -i "../${_src}"
fi
done
@@ -60,28 +51,26 @@ prepare() {
#sed -E -e 's:SUBDIRS=([^ ]+) :M=\1 &:g' -i 'module/Makefile'
sed -e 's:-Werror::g' -i 'Makefile'
- set +u
}
build() {
- set -u
- # We only need to build the library in this step, dmks will build the module
- #cd "${_srcdir}/library"
- # DKMS builds are hard to debug. We build it here and throw it away.
cd "${_srcdir}"
+ # DKMS builds are hard to debug. We can build it here to debug the errors.
+ if :; then
+ # We only need to build the library in this step, dmks will build the module
+ cd 'library'
+ fi
CFLAGS="${CFLAGS/-fno-plt/}"
make
- set +u
}
package() {
- set -u
cd "${_srcdir}"
install -Dpm755 "library/lib${pkgname%-git}.so"* -t "${pkgdir}/usr/lib/"
+
pushd "${pkgdir}/usr/lib/" > /dev/null
local _libs=(*.so.*)
if [ "${#_libs[@]}" -ne 1 ]; then
- set +u
echo "Too many libs"
false
fi
@@ -94,6 +83,5 @@ package() {
local _DKMS="${pkgdir}/usr/src/${pkgname%-git}-${_pkgver}"
install -Dpm644 module/* -t "${_DKMS}/"
make -j1 -C "${_DKMS}" clean
- set +u
+ rm -f "${_DKMS}/evdi.mod"
}
-set +u
diff --git a/evdi-git.Changelog b/evdi-git.Changelog
deleted file mode 100644
index 30bbda7fe392..000000000000
--- a/evdi-git.Changelog
+++ /dev/null
@@ -1,12 +0,0 @@
-v1.3.43
-Adding support for indicating an area limit a client that connects to EVDI has.
-
-v1.3.42
-Fixes for Kernels 4.9 and 4.10.
-API change: Extension of evdi_connect function, allowing to register modes that the client supports, regardless of the fact they are not necessarily listed in the EDID of a monitor.
-
-v1.2.64
-Highlights: fixes for kernel 4.8.
-
-v1.2.55
-Module and library code to be included in DisplayLink USB Graphics Software for Ubuntu, version 1.2.
diff --git a/evdi-git.install b/evdi-git.install
deleted file mode 100644
index 088935d44d3d..000000000000
--- a/evdi-git.install
+++ /dev/null
@@ -1,21 +0,0 @@
-# old version (without -$pkgrel): ${1%%-*}
-# new version (without -$pkgrel): ${2%%-*}
-
-post_install() {
- cat << EOF
-Steps:
-
-0. Install this package
-
-1. Install display driver package
-
-2. Reboot or
-
-2a. sudo modprobe evdi
-2b. dmesg -w # watch for evdi messages
-2c. Replug USB display device
-
-3. Enable screen
-EOF
-}
-
diff --git a/relro.patch b/relro.patch
deleted file mode 100644
index d63d0887b9fb..000000000000
--- a/relro.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/library/Makefile b/library/Makefile
-index 9b4e856..8a13662 100644
---- a/library/Makefile
-+++ b/library/Makefile
-@@ -14,5 +14,5 @@ clean:
- $(CC) -c -o $@ $< $(CFLAGS)
-
- libevdi.so: evdi_lib.o
-- $(CC) $^ -o $@ -lc -lgcc -shared -Wl,-soname,libevdi.so.0
-+ $(CC) $^ -o $@ -lc -lgcc -shared -Wl,-soname,libevdi.so.0 $(LDFLAGS)
-