summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-07-23 16:24:06 -0400
committerChris Severance2019-07-23 16:24:06 -0400
commitca8748e9b37152ad33d6966ce636da3db219f9db (patch)
tree03b35d945807f04e1f6291cf369837ae9f96a5b3
parentbe253824780074265684ba028703e879d860d5eb (diff)
downloadaur-ca8748e9b37152ad33d6966ce636da3db219f9db.tar.gz
autu: Update to 1.6.2_2_g75536ec-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
-rw-r--r--relro.patch11
3 files changed, 47 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00b821b3d641..9b0f6ef348f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 1 01:34:47 UTC 2018
+# Tue Jul 23 20:24:05 UTC 2019
pkgbase = evdi-git
- pkgdesc = A Linux® kernel module that enables management of multiple screens. Git version.
- pkgver = 1.5.0_r2.r0.gdc3c9d6
+ pkgdesc = kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video git version.
+ pkgver = 1.6.2_2_g75536ec
pkgrel = 1
url = https://github.com/DisplayLink/evdi
install = evdi-git.install
@@ -13,10 +13,14 @@ pkgbase = evdi-git
makedepends = git
makedepends = libdrm
depends = dkms
- provides = evdi=1.5.0_r2
+ provides = evdi=1.6.2_2_g75536ec
conflicts = evdi
source = git+https://github.com/DisplayLink/evdi/
+ source = relro.patch
+ md5sums = SKIP
+ md5sums = 05e64dd295a66c030139d0c8f6f7013b
sha256sums = SKIP
+ sha256sums = ff03b5a804af826e6b0678cd4d821b5ecd2c5bf04ea7c465751f83b28e928786
pkgname = evdi-git
diff --git a/PKGBUILD b/PKGBUILD
index b8faa15c7745..2b58ac5abbd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: ajs124
+# Tested with Kernel 4.16, Dell D3000 SuperSpeed USB 3.0 Docking Station, 17e9:4318 DisplayLink
+
set -u
pkgname='evdi-git'
-pkgver=1.5.0_r2.r0.gdc3c9d6
+pkgver=1.6.2_2_g75536ec
_pkgver="${pkgver%%.r*}"
pkgrel=1
-pkgdesc="A Linux® kernel module that enables management of multiple screens."
-pkgdesc+=' Git version.'
+pkgdesc='kernel module that enables management of multiple screens, primarily for DisplayLink USB VGA DVI HDMI DisplayPort video'
+pkgdesc+=' git version.'
arch=('i686' 'x86_64')
url='https://github.com/DisplayLink/evdi'
license=('GPL')
@@ -18,13 +20,19 @@ conflicts=('evdi')
install=${pkgname}.install
changelog="${pkgname}.Changelog"
_srcdir="${pkgname%-git}"
-source=("git+https://github.com/DisplayLink/evdi/")
-sha256sums=('SKIP')
+source=(
+ 'git+https://github.com/DisplayLink/evdi/'
+ 'relro.patch'
+)
+md5sums=('SKIP'
+ '05e64dd295a66c030139d0c8f6f7013b')
+sha256sums=('SKIP'
+ 'ff03b5a804af826e6b0678cd4d821b5ecd2c5bf04ea7c465751f83b28e928786')
pkgver() {
set -u
cd "${_srcdir}"
- # extra -r interfers with version management
+ # occasional extra -r interfers with version management
local _t1="$(git describe --tags)" # v1.5.0-r2
local _t1a="${_t1//-/_}"
local _t2="$(git describe --long --tags)" # v1.5.0-r2-0-gdc3c9d6
@@ -33,6 +41,20 @@ pkgver() {
set +u
}
+prepare() {
+ set -u
+ cd "${_srcdir}"
+ local _src
+ for _src in "${source[@]}"; do
+ _src="${_src%%::*}"
+ _src="${_src##*/}"
+ if [[ "${_src}" = *.patch ]]; then
+ patch -Np1 -i "../${_src}"
+ fi
+ done
+ set +u
+}
+
build() {
set -u
# We only need to build the library in this step, dmks will build the module
diff --git a/relro.patch b/relro.patch
new file mode 100644
index 000000000000..d63d0887b9fb
--- /dev/null
+++ b/relro.patch
@@ -0,0 +1,11 @@
+diff --git a/library/Makefile b/library/Makefile
+index 9b4e856..8a13662 100644
+--- a/library/Makefile
++++ b/library/Makefile
+@@ -14,5 +14,5 @@ clean:
+ $(CC) -c -o $@ $< $(CFLAGS)
+
+ libevdi.so: evdi_lib.o
+- $(CC) $^ -o $@ -lc -lgcc -shared -Wl,-soname,libevdi.so.0
++ $(CC) $^ -o $@ -lc -lgcc -shared -Wl,-soname,libevdi.so.0 $(LDFLAGS)
+