summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorajs1242017-08-10 19:05:08 +0200
committerajs1242017-08-10 19:05:08 +0200
commitf84eab0ce70a4dcd2c9b40a4f07d76fc4482620a (patch)
tree9a815d573d4c1d928cc5fcccd2cd011302828348
downloadaur-f84eab0ce70a4dcd2c9b40a4f07d76fc4482620a.tar.gz
initial commit. why are all of you incompetent?
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
-rw-r--r--evdi-git.Changelog12
-rw-r--r--evdi-git.install20
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d02757847bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Do Aug 10 17:04:04 UTC 2017
+pkgbase = evdi-git
+ pkgdesc = A Linux® kernel module that enables management of multiple screens. Git version.
+ pkgver = 1.0.68.r83.gee1c578
+ pkgrel = 1
+ url = https://github.com/DisplayLink/evdi
+ install = evdi-git.install
+ changelog = evdi-git.Changelog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = dkms
+ provides = evdi
+ conflicts = evdi
+ source = git+https://github.com/DisplayLink/evdi/
+ md5sums = SKIP
+
+pkgname = evdi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9243a63a02de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: ajs124
+
+pkgname=evdi-git
+pkgver=1.0.68.r83.gee1c578
+pkgrel=1
+pkgdesc="A Linux® kernel module that enables management of multiple screens. Git version."
+arch=('i686' 'x86_64')
+url="https://github.com/DisplayLink/evdi"
+license=('GPL')
+depends=(dkms)
+makedepends=(git)
+install=$pkgname.install
+changelog=$pkgname.Changelog
+source=(git+https://github.com/DisplayLink/evdi/)
+md5sums=(SKIP)
+conflicts=(evdi)
+provides=(evdi)
+
+pkgver() {
+ cd ${pkgname/-git/}
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ # We only need to build the library in this step, dmks will build the module
+ cd ${pkgname/-git/}/library
+ make
+}
+
+package() {
+ # Predfine some target folders
+ SRCDIR="$pkgdir/usr/src/${pkgname/-git/}-$pkgver" # This one is needed for dkms
+ LIBNAME=lib${pkgname/-git/}
+
+ cd ${pkgname/-git/}
+
+ install -D -m 755 library/$LIBNAME.so $pkgdir/usr/lib/$LIBNAME.so
+
+ install -d $SRCDIR
+ install -D -m 755 module/* $SRCDIR
+}
diff --git a/evdi-git.Changelog b/evdi-git.Changelog
new file mode 100644
index 000000000000..30bbda7fe392
--- /dev/null
+++ b/evdi-git.Changelog
@@ -0,0 +1,12 @@
+v1.3.43
+Adding support for indicating an area limit a client that connects to EVDI has.
+
+v1.3.42
+Fixes for Kernels 4.9 and 4.10.
+API change: Extension of evdi_connect function, allowing to register modes that the client supports, regardless of the fact they are not necessarily listed in the EDID of a monitor.
+
+v1.2.64
+Highlights: fixes for kernel 4.8.
+
+v1.2.55
+Module and library code to be included in DisplayLink USB Graphics Software for Ubuntu, version 1.2.
diff --git a/evdi-git.install b/evdi-git.install
new file mode 100644
index 000000000000..89a76551a680
--- /dev/null
+++ b/evdi-git.install
@@ -0,0 +1,20 @@
+# old version (without -$pkgrel): ${1%%-*}
+# new version (without -$pkgrel): ${2%%-*}
+
+post_install() {
+ echo 'DKMS install...'
+ dkms install evdi/${1%%-*}
+}
+
+pre_upgrade() {
+ pre_remove ${2%%-*}
+}
+
+post_upgrade() {
+ post_install ${1%%-*}
+}
+
+pre_remove() {
+ echo 'DKMS remove...'
+ dkms remove evdi/${1%%-*} --all
+}