summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Labonte2017-02-11 01:29:00 -0500
committerJeff Labonte2017-02-11 01:29:00 -0500
commitf4d11157109b67516f0a52e1517e14e6d1bc2f14 (patch)
tree41a00aa88f82bc8ce1ca0d0688ea7eec4bf9910d
downloadaur-f4d11157109b67516f0a52e1517e14e6d1bc2f14.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD56
-rwxr-xr-xevelauncher.desktop5
-rw-r--r--icon.pngbin0 -> 41965 bytes
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f3f8cf50107
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = evelauncher
+ pkgdesc = Unofficial Eve Online Launcher. Simplify Installation
+ pkgver = 1104891
+ pkgrel = 1
+ url = https://binaries.eveonline.com/evelauncher-1104891.tar.gz
+ arch = any
+ license = custom
+ depends = wine
+ source = https://binaries.eveonline.com/evelauncher-1104891.tar.gz
+ source = evelauncher.desktop
+ source = icon.png
+ md5sums = a99e75f1de68531f86f52b30ea4ee2cd
+ md5sums = d6d1437552264f74f64a745d9a3c9d3f
+ md5sums = 37c1b0799f8e671b298c288d900dd7f0
+
+pkgname = evelauncher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75e71159dbb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Jeff Labonte jeff.labonte12@gmail.com
+pkgname=evelauncher
+pkgver=1104891
+pkgrel=1
+epoch=
+pkgdesc="Unofficial Eve Online Launcher. Simplify Installation"
+arch=('any')
+url="https://binaries.eveonline.com/evelauncher-1104891.tar.gz"
+license=('custom')
+groups=()
+depends=('wine')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "https://binaries.eveonline.com/evelauncher-1104891.tar.gz"
+ "evelauncher.desktop"
+ "icon.png")
+noextract=()
+md5sums=(
+ 'a99e75f1de68531f86f52b30ea4ee2cd'
+ 'd6d1437552264f74f64a745d9a3c9d3f'
+ '37c1b0799f8e671b298c288d900dd7f0'
+)
+
+package() {
+ # Install the main files.
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/evelauncher/." "${pkgdir}/opt/${pkgname}"
+ # Exec bit
+ chmod 755 "${pkgdir}/opt/${pkgname}/evelauncher"
+
+
+ # Desktop Entry
+ install -d "${pkgdir}/usr/share/applications"
+ install "${srcdir}/evelauncher.desktop" "${pkgdir}/usr/share/applications"
+
+ install -d "${pkgdir}/opt/${pkgname}"
+ install "${srcdir}/icon.png" "${pkgdir}/opt/${pkgname}"
+
+ # Main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/evelauncher" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/evelauncher.desktop b/evelauncher.desktop
new file mode 100755
index 000000000000..a29171e2e1f4
--- /dev/null
+++ b/evelauncher.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Type=Application
+Name=Eve Online Launcher
+Exec=sh /opt/evelauncher/evelauncher.sh
+Icon=/opt/evelauncher/icon.png
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..44e0b7ffe89e
--- /dev/null
+++ b/icon.png
Binary files differ