summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Glidic2018-03-07 17:37:44 +0100
committerQuentin Glidic2018-03-07 18:05:37 +0100
commit92ec8f138cb8a2f095fc283ae918df847fc9d68b (patch)
tree5b3306a3008b101732b7c57a64be09a992204ba3
parent982dd2892d1278d88c8b53af1e9ec2c18a1a56e8 (diff)
downloadaur-92ec8f138cb8a2f095fc283ae918df847fc9d68b.tar.gz
eventd: Bump to 0.24.0
Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f750807253d..a86ae113ede1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = eventd
pkgdesc = A small daemon to act on remote or local events
- pkgver = 0.23.0
- pkgrel = 4
+ pkgver = 0.24.0
+ pkgrel = 1
url = https://www.eventd.org
arch = i686
arch = x86_64
license = GPL3
license = LGPL3
license = MIT
+ makedepends = git
makedepends = meson
makedepends = pkg-config
makedepends = ninja
@@ -20,6 +21,8 @@ pkgbase = eventd
depends = pango
depends = libsystemd
depends = libxcb
+ depends = libxkbcommon>=0.4.1
+ depends = libxkbcommon-x11
depends = util-linux
depends = xcb-util
depends = xcb-util-wm
@@ -28,8 +31,8 @@ pkgbase = eventd
optdepends = librsvg: SVG images support
optdepends = libsoup: WebSocket support
options = !strip
- source = https://www.eventd.org/download/eventd/eventd-0.23.0.tar.xz
- sha256sums = fe4905d79c8312686c11db28783364b84216289fd1a7fa58db3137135047dc9e
+ source = https://www.eventd.org/download/eventd/eventd-0.24.0.tar.xz
+ sha256sums = 668f5a56eb156712181176fc4b4f87cd52de919af6e661504ae9e543b4b226a3
pkgname = eventd
diff --git a/PKGBUILD b/PKGBUILD
index 0aae230b8f24..6f9f2c043304 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Quentin Glidic <sardemff7@eventd.org>
pkgname=eventd
-pkgver=0.23.0
+pkgver=0.24.0
_pkgdir=${pkgname}-${pkgver}
-pkgrel=4
+pkgrel=1
pkgdesc="A small daemon to act on remote or local events"
arch=(
i686
@@ -23,11 +23,14 @@ depends=(
pango
libsystemd
libxcb
+ 'libxkbcommon>=0.4.1'
+ libxkbcommon-x11
util-linux
xcb-util
xcb-util-wm
)
makedepends=(
+ git
meson
pkg-config
ninja
@@ -47,17 +50,17 @@ source=(
https://www.eventd.org/download/${pkgname}/${pkgname}-${pkgver}.tar.xz
)
sha256sums=(
- fe4905d79c8312686c11db28783364b84216289fd1a7fa58db3137135047dc9e
+ 668f5a56eb156712181176fc4b4f87cd52de919af6e661504ae9e543b4b226a3
)
build() {
local params=(
--prefix=/usr
- -Denable-systemd=true
- -Denable-introspection=false
- -Denable-nd-wayland=false
- -Denable-im=false
- -Denable-sound=false
+ -Dsystemd=true
+ -Dintrospection=false
+ -Dnd-wayland=false
+ -Dim=false
+ -Dsound=false
)
cd "${srcdir}"/${_pkgdir}