summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoloursofnoise2022-10-10 15:29:25 -0700
committercoloursofnoise2022-10-10 15:29:25 -0700
commit8a04984e5f1c8da4f9492be3e838fbe11b91bccb (patch)
treeda9fac083e53ee1f77ee76e22d94ad0d42cae597
downloadaur-8a04984e5f1c8da4f9492be3e838fbe11b91bccb.tar.gz
Create everest-mons package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7028f8bc767
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = everest-mons
+ pkgdesc = Command-Line Installer and Manager for Celeste Modding
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://github.com/coloursofnoise/mons
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-dnfile
+ depends = python-pefile
+ depends = python-click
+ depends = python-tqdm
+ depends = python-xxhash
+ depends = python-pyyaml
+ depends = python-urllib3
+ conflicts = mons
+ source = mons-1.4.1.tar.gz::https://files.pythonhosted.org/packages/source/m/mons/mons-1.4.1.tar.gz
+ md5sums = 18d21726e416aebbb16f6a1229b9229d
+
+pkgname = everest-mons
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5003ef26ccd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: coloursofnoise <coloursofthenoise at google mail>
+pkgname=everest-mons
+_name=mons
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Command-Line Installer and Manager for Celeste Modding"
+url="https://github.com/coloursofnoise/mons"
+arch=('any')
+license=('MIT')
+depends=('python' 'python-dnfile' 'python-pefile' 'python-click' 'python-tqdm' 'python-xxhash' 'python-pyyaml' 'python-urllib3')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+conflicts=('mons')
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('18d21726e416aebbb16f6a1229b9229d')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}