summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoloursofnoise2022-11-16 23:02:27 -0800
committercoloursofnoise2022-11-16 23:02:27 -0800
commitab86aedd585b74adc39be4ad3a6e4e1c0304ab50 (patch)
treefff3c5305d2e79fbabb306177648e64f9888fc3d
parent38c05a24adc89bcbc378e621b75113352327e770 (diff)
downloadaur-ab86aedd585b74adc39be4ad3a6e4e1c0304ab50.tar.gz
v1.4.4 include 'setuptools-scm' build dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 265e1a377eda..6daa3df514fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = everest-mons
pkgdesc = Command-Line Installer and Manager for Celeste Modding
- pkgver = 1.4.3
+ pkgver = 1.4.4
pkgrel = 1
url = https://github.com/coloursofnoise/mons
arch = any
@@ -8,6 +8,7 @@ pkgbase = everest-mons
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python
depends = python-dnfile
depends = python-pefile
@@ -17,7 +18,7 @@ pkgbase = everest-mons
depends = python-pyyaml
depends = python-urllib3
conflicts = mons
- source = mons-1.4.3.tar.gz::https://files.pythonhosted.org/packages/source/m/mons/mons-1.4.3.tar.gz
- md5sums = eee1e49136296f280316cc06c7215dbf
+ source = mons-1.4.4.tar.gz::https://files.pythonhosted.org/packages/source/m/mons/mons-1.4.4.tar.gz
+ md5sums = 6ace58773bab8793819958ccb29dc3ee
pkgname = everest-mons
diff --git a/PKGBUILD b/PKGBUILD
index 947b6bb898ba..fd5221c655d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: coloursofnoise <coloursofthenoise at google mail>
pkgname=everest-mons
_name=mons
-pkgver=1.4.3
+pkgver=1.4.4
pkgrel=1
pkgdesc="Command-Line Installer and Manager for Celeste Modding"
url="https://github.com/coloursofnoise/mons"
arch=('any')
license=('MIT')
depends=('python' 'python-dnfile' 'python-pefile' 'python-click' 'python-tqdm' 'python-xxhash' 'python-pyyaml' 'python-urllib3')
-makedepends=('python-build' 'python-installer' 'python-wheel')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
conflicts=('mons')
source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('eee1e49136296f280316cc06c7215dbf')
+md5sums=('6ace58773bab8793819958ccb29dc3ee')
build() {
cd "${_name}-${pkgver}"