summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Malik2021-07-17 13:53:36 +0200
committerKonrad Malik2021-07-17 13:53:36 +0200
commit02909aae13d13fc58bec972e0bf73da0d2c502b7 (patch)
tree075f52d0bd57f7a843da316c84569e5217ec3451
downloadaur-02909aae13d13fc58bec972e0bf73da0d2c502b7.tar.gz
10.17.6
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
-rw-r--r--evernote-for-linux-bin.install23
-rwxr-xr-xprepare.sh4
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6abc27736373
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = evernote-for-linux-bin
+ pkgdesc = Official Evernote client for Windows repackaged for Linux
+ pkgver = 10.17.6
+ pkgrel = 1
+ url = https://github.com/search5/Evernote-for-Linux
+ install = evernote-for-linux-bin.install
+ arch = x86_64
+ license = custom
+ depends = gtk3
+ depends = libnotify
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-core
+ depends = util-linux-libs
+ depends = libappindicator-gtk3
+ depends = libsecret
+ provides = evernote
+ conflicts = evernote-beta-bin
+ noextract = evernote-client_10.17.6_amd64.deb
+ source = https://github.com/search5/Evernote-for-Linux/releases/download/10.17.6-linux-ddl-ga-2775/evernote-client_10.17.6_amd64.deb
+ sha256sums = 8f8c2fd10c65c99c3a97c91438779ea4405474747c45f6b7efcdfeea0a3315d2
+
+pkgname = evernote-for-linux-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c0550e6719d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.deb
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..743450b90df8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Konrad Malik (https://konradmalik.github.io/)
+
+pkgname=evernote-for-linux-bin
+pkgver=10.17.6
+buildver=2775
+pkgrel=1
+pkgdesc="Official Evernote client for Windows repackaged for Linux"
+arch=('x86_64')
+url="https://github.com/search5/Evernote-for-Linux"
+license=('custom')
+provides=('evernote')
+depends=(
+ 'gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils'
+ 'at-spi2-core' 'util-linux-libs' 'libappindicator-gtk3' 'libsecret'
+)
+optdepends=()
+conflicts=("evernote-beta-bin")
+replaces=()
+install=$pkgname.install
+source=(
+ "https://github.com/search5/Evernote-for-Linux/releases/download/${pkgver}-linux-ddl-ga-${buildver}/evernote-client_${pkgver}_amd64.deb"
+ )
+noextract=("evernote-client_${pkgver}_amd64.deb")
+sha256sums=(
+ '8f8c2fd10c65c99c3a97c91438779ea4405474747c45f6b7efcdfeea0a3315d2'
+)
+
+package() {
+ # extract only data
+ bsdtar -O -xf "evernote-client_${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+}
diff --git a/evernote-for-linux-bin.install b/evernote-for-linux-bin.install
new file mode 100644
index 000000000000..5a37ec3a5ae8
--- /dev/null
+++ b/evernote-for-linux-bin.install
@@ -0,0 +1,23 @@
+## arg 1: the new package version
+post_install() {
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ post_remove $2
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+## arg 1: the old package version
+post_remove() {
+ # Delete the link to the binary
+ rm -f '/usr/bin/evernote-client'
+}
diff --git a/prepare.sh b/prepare.sh
new file mode 100755
index 000000000000..99b9d943ba18
--- /dev/null
+++ b/prepare.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+set -e
+
+makepkg --printsrcinfo > .SRCINFO