summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Miller2021-11-16 00:26:58 +1300
committerJoey Miller2021-11-16 00:26:58 +1300
commitd5c51f2c54cab8033d505ea1468cbf2f1a25eaff (patch)
tree5a875f16d32bc39378211142371e81d5d907f09b
downloadaur-d5c51f2c54cab8033d505ea1468cbf2f1a25eaff.tar.gz
Created AUR package 'eversticky'
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d8596026797
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eversticky
+ pkgdesc = A sticky note client that sync to Evernote.
+ pkgver = 0.95.0
+ pkgrel = 1
+ url = https://eversticky.joeeey.com
+ arch = x86_64
+ license = GPL3
+ license = MIT
+ depends = qt5-webengine>=5.12.2
+ depends = qt5-x11extras>=5.12.2
+ conflicts = eversticky
+ replaces = eversticky
+ source = https://github.com/itsmejoeeey/eversticky/releases/download/v0.95.0/eversticky_0.95.0-1_amd64.deb
+ sha256sums = fa14a88e01c8e640b0b44867d942ce160aaa290a96c65642c833f58d907ae982
+
+pkgname = eversticky
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2aafba7208fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Joey Miller <maintainer at joeeey dot com>
+
+pkgname=eversticky
+pkgver=0.95.0
+pkgrel=1
+pkgdesc="A sticky note client that sync to Evernote."
+arch=('x86_64')
+url="https://eversticky.joeeey.com"
+license=('GPL3' 'MIT')
+depends=("qt5-webengine>=5.12.2" "qt5-x11extras>=5.12.2" )
+conflicts=("eversticky")
+replaces=("eversticky")
+source=("https://github.com/itsmejoeeey/eversticky/releases/download/v${pkgver}/${pkgname}_${pkgver}-${pkgrel}_amd64.deb")
+sha256sums=('fa14a88e01c8e640b0b44867d942ce160aaa290a96c65642c833f58d907ae982')
+
+package() {
+ echo " -> Extracting the installer..."
+
+ # Extract binary and icons from data.tar.xz
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+
+ # Extract license information from control.tar.xz
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ bsdtar -xf control.tar.xz -C "${pkgdir}/usr/share/licenses/${pkgname}" ./copyright
+ mv "${pkgdir}/usr/share/licenses/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Fix permissions
+ find "${pkgdir}" -type d -exec chmod 755 {} \;
+ chmod 755 "${pkgdir}/usr/bin/${pkgname}"
+}