summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorboopsies2015-11-27 08:52:40 +0000
committerboopsies2015-11-27 08:52:40 +0000
commite5165099487b3df762b1491996ab8963dad93334 (patch)
treec3842e6c4349089b1598507755a55ce68b05280c
downloadaur-e5165099487b3df762b1491996ab8963dad93334.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
-rw-r--r--evhttpclient-unistd.patch8
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b980fc6fe4b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = evhttpclient-git
+ pkgdesc = An HTTP client in C++ that uses the libev event library.
+ pkgver = r6.8acdd49
+ pkgrel = 1
+ url = https://github.com/jspotter/evhttpclient
+ arch = x86_64
+ arch = i686
+ license = mixed
+ depends = libev
+ source = git+https://github.com/jspotter/evhttpclient.git
+ source = evhttpclient-unistd.patch
+ md5sums = SKIP
+ md5sums = 8bfd9d9082eb83c9569fe994ffec1a66
+
+pkgname = evhttpclient-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee5a605abb6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: boop <actually.boop@gmail.com>
+pkgname=evhttpclient-git
+_pkgname=evhttpclient
+pkgver=r6.8acdd49
+pkgrel=1
+pkgdesc="An HTTP client in C++ that uses the libev event library."
+arch=('x86_64' 'i686')
+url="https://github.com/jspotter/evhttpclient"
+license=('mixed')
+depends=('libev')
+source=("git+https://github.com/jspotter/evhttpclient.git"
+ "evhttpclient-unistd.patch")
+md5sums=('SKIP'
+ '8bfd9d9082eb83c9569fe994ffec1a66')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ patch -p1 -i "$srcdir/evhttpclient-unistd.patch"
+}
+
+build() {
+ cd "$_pkgname"
+ make build
+}
+
+package() {
+ cd "$_pkgname"
+
+ install -Dm644 "evhttpclient.h" "$pkgdir/usr/include/evhttpclient.h"
+ install -Dm644 "url.h" "$pkgdir/usr/include/url.h"
+# install -Dm644 "http_parser.h" "$pkgdir/usr/include/http_parser.h"
+ install -sDm644 "libevhttpclient.so" "$pkgdir/usr/lib/libevhttpclient.so"
+}
diff --git a/evhttpclient-unistd.patch b/evhttpclient-unistd.patch
new file mode 100644
index 000000000000..84c61bf1cd27
--- /dev/null
+++ b/evhttpclient-unistd.patch
@@ -0,0 +1,8 @@
+diff -aur evhttpclient/evhttpclient.cpp mod/evhttpclient.cpp
+--- evhttpclient/evhttpclient.cpp 2015-11-26 18:57:08.788012425 +0000
++++ mod/evhttpclient.cpp 2015-11-26 19:09:15.408547005 +0000
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include <algorithm>
+ #include <netdb.h>
+ #include <fcntl.h>