summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYichao Zhou2018-01-18 21:51:56 -0800
committerYichao Zhou2018-01-18 21:51:56 -0800
commit5ac239d07142b15de8b270543be1522cb0153bfa (patch)
treec55284c2b0e65e7dc2df8da9f3af0d6cfc2b1a1c
parent87ca509fa51c56ae57ad7cc150d1619860461749 (diff)
downloadaur-5ac239d07142b15de8b270543be1522cb0153bfa.tar.gz
Version bump
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 33 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2bdc06a68ca..b248a21c3e0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Sun Jul 31 20:56:43 UTC 2016
+# Fri Jan 19 05:51:53 UTC 2018
pkgbase = evince-lcdfilter
pkgdesc = Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex support with gedit, comics books (cbr,cbz,cb7 and cbt))
- pkgver = 3.20.1
- pkgrel = 0
+ pkgver = 3.26.0+14+g2a499547
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Evince
- arch = i686
arch = x86_64
groups = gnome
license = GPL
@@ -17,11 +16,13 @@ pkgbase = evince-lcdfilter
makedepends = docbook-xsl
makedepends = python
makedepends = gtk-doc
+ makedepends = git
+ makedepends = gnome-common
depends = gtk3
depends = libgxps
depends = libspectre
depends = gsfonts
- depends = poppler-glib-lcdfilter
+ depends = poppler-glib
depends = djvulibre
depends = t1lib
depends = dconf
@@ -32,12 +33,10 @@ pkgbase = evince-lcdfilter
depends = gst-plugins-base-libs
optdepends = texlive-bin: DVI support
optdepends = gvfs: bookmark support and session saving
- provides = evince=3.20.1
- conflicts = evince
options = !emptydirs
- source = https://download.gnome.org/sources/evince/3.20/evince-3.20.1.tar.xz
+ source = git+https://git.gnome.org/browse/evince#commit=2a4995479ccf65f5bd15df13f9b6c810c3156b58
source = evince-poppler-subpixel.patch
- sha256sums = fc7ac23036939c24f02e9fed6dd6e28a85b4b00b60fa4b591b86443251d20055
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = evince-lcdfilter
diff --git a/PKGBUILD b/PKGBUILD
index b84c09ed9058..2c3952039ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,44 @@
# Maintainer: Yichao Zhou <broken.zhou@gmail.com>
-_pkgname=evince
pkgname=evince-lcdfilter
-pkgver=3.20.1
-pkgrel=0
+_pkgname=evince
+pkgver=3.26.0+14+g2a499547
+pkgrel=2
pkgdesc="Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex support with gedit, comics books (cbr,cbz,cb7 and cbt))"
url="https://wiki.gnome.org/Apps/Evince"
-arch=(i686 x86_64)
+arch=(x86_64)
license=(GPL)
-depends=(gtk3 libgxps libspectre gsfonts poppler-glib-lcdfilter djvulibre t1lib dconf
+depends=(gtk3 libgxps libspectre gsfonts poppler-glib djvulibre t1lib dconf
libsecret gsettings-desktop-schemas gnome-desktop libarchive
gst-plugins-base-libs)
makedepends=(itstool libnautilus-extension texlive-bin gobject-introspection
- intltool docbook-xsl python gtk-doc)
+ intltool docbook-xsl python gtk-doc git gnome-common)
optdepends=('texlive-bin: DVI support'
- 'gvfs: bookmark support and session saving')
-provides=("evince=$pkgver")
-conflicts=("evince")
+ 'gvfs: bookmark support and session saving')
groups=(gnome)
options=('!emptydirs')
-source=(https://download.gnome.org/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz
+_commit=2a4995479ccf65f5bd15df13f9b6c810c3156b58 # master
+source=("git+https://git.gnome.org/browse/evince#commit=$_commit"
evince-poppler-subpixel.patch)
-sha256sums=('fc7ac23036939c24f02e9fed6dd6e28a85b4b00b60fa4b591b86443251d20055'
+sha256sums=('SKIP'
'SKIP')
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+
build() {
- cd $_pkgname-$pkgver
+ cd $_pkgname
patch -Np1 -i ../evince-poppler-subpixel.patch
+ BROWSER_PLUGIN_DIR=/usr/lib/epiphany/plugins \
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--libexecdir=/usr/lib/$_pkgname \
--disable-static \
@@ -42,8 +53,7 @@ build() {
--enable-comics \
--enable-gtk-doc \
--enable-multimedia \
- --disable-schemas-compile \
- --disable-browser-plugin
+ --disable-schemas-compile
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -51,6 +61,6 @@ build() {
}
package() {
- cd $_pkgname-$pkgver
+ cd $pkgname
make DESTDIR="$pkgdir" install
}