summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2017-09-18 17:53:32 +0200
committerBruno Pagani2017-09-18 17:53:32 +0200
commitf6961b9129caa0a08fdb07e9c9b90c3979f72fb2 (patch)
tree69d3048d83e95a6b387e22957925ba6031bb0321
parente26d2bbf3afe07c61ea8012ebf479b66aaf29257 (diff)
downloadaur-f6961b9129caa0a08fdb07e9c9b90c3979f72fb2.tar.gz
Revamp PKGBUILD with the acquired knowledge
gtk-doc and gobject-introspection are mostly build-time changes that are useful in most cases (though I’m not sure what might use gir from evince). Also add ability to enable Nautilus extension, even though it does not appear to be working.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d81f79e7394..8ecf4b36071e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,12 @@ pkgbase = evince-light
makedepends = itstool
makedepends = intltool
makedepends = python
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
depends = gtk3
depends = libsm
depends = poppler-glib
+ optdepends = gvfs: bookmark support and session saving
provides = evince
conflicts = evince
source = https://download.gnome.org/sources/evince/3.26/evince-3.26.0.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 294b9dea7c48..363688bbaefa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@ _dvi="no" # DVI file support
_tiff="no" # TIFF file support
_xps="no" # XPS file support
_comics="no" # CB[ZR7T] comics file support
-_bookmarks="no" # Bookmarks and annotations support
_previewer="no" # GNOME Document Previewer support
_thumbnailer="no" # GNOME Thumbnailer support
+_nautilus="no" # GNOME Files support
_pkgname=evince
pkgname=${_pkgname}-light
@@ -31,9 +31,12 @@ depends=('gtk3' 'libsm')
[[ "${_dvi}" == "yes" ]] && depends+=('texlive-bin')
[[ "${_xps}" == "yes" ]] && depends+=('libgxps')
[[ "${_comics}" == "yes" ]] && depends+=('libarchive')
-[[ "${_bookmarks}" == "yes" ]] && depends+=('gvfs')
-makedepends=('itstool' 'intltool' 'python')
+makedepends=('itstool' 'intltool' 'python' 'gobject-introspection' 'gtk-doc')
+
+[[ "${_nautilus}" == "yes" ]] && makedepends+=('libnautilus-extension')
+
+optdepends=('gvfs: bookmark support and session saving')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("https://download.gnome.org/sources/${_pkgname}/${pkgver:0:4}/${_pkgname}-${pkgver}.tar.xz")
@@ -53,6 +56,7 @@ build() {
[[ "${_tiff}" == "yes" ]] && _build_cfg+='--enable-tiff ' || _build_cfg+='--disable-tiff '
[[ "${_previewer}" == "yes" ]] && _build_cfg+='--enable-previewer ' || _build_cfg+='--disable-previewer '
[[ "${_thumbnailer}" == "yes" ]] && _build_cfg+='--enable-thumbnailer ' || _build_cfg+='--disable-thumbnailer '
+ [[ "${_nautilus}" == "yes" ]] && _build_cfg+='--enable-nautilus ' || _build_cfg+='--disable-nautilus '
./configure \
--sysconfdir=/etc \
@@ -60,20 +64,20 @@ build() {
--libexecdir=/usr/lib/${_pkgname} \
--localstatedir=/var \
--with-platform=gnome \
+ --disable-static \
--disable-debug \
--disable-maintainer-mode \
--disable-schemas-compile \
+ --disable-libgnome-desktop \
+ --enable-dbus \
+ --enable-gtk-doc \
+ --enable-introspection \
--enable-viewer \
${_build_cfg} \
--enable-t1lib \
- --disable-nautilus \
--disable-browser-plugin \
- --disable-gtk-doc \
- --disable-introspection \
- --enable-dbus \
--without-keyring \
- --with-gtk-unix-print \
- --disable-libgnome-desktop
+ --with-gtk-unix-print
make
}