summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYiyao Yu2019-06-21 12:06:49 +0800
committerYiyao Yu2019-06-21 12:06:49 +0800
commitad52f3e0bd0ec0928a0ce1da929cb7629703e109 (patch)
tree2a85935b18e174e7552ccd7c77b3a8fbfbd231b3
parent189b130cdfabaf09ddb7372285a0af5dd8df234c (diff)
downloadaur-ad52f3e0bd0ec0928a0ce1da929cb7629703e109.tar.gz
3.32.0-1: New upstream + update, updated makedepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61f808d3fe7b..126583d8eb8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Oct 27 12:05:10 UTC 2018
pkgbase = evince-no-gnome
pkgdesc = GTK3 document viewer, complete features, no gnome dependencies
- pkgver = 3.30.2
+ pkgver = 3.32.0
pkgrel = 1
url = https://wiki.gnome.org/Apps/Evince
arch = i686
@@ -16,6 +14,7 @@ pkgbase = evince-no-gnome
makedepends = python
makedepends = gtk-doc
makedepends = gnome-common
+ makedepends = appstream-glib
depends = dconf
depends = gtk3
depends = libgxps
@@ -32,7 +31,7 @@ pkgbase = evince-no-gnome
conflicts = evince
conflicts = evince-light
options = !emptydirs
- source = git+https://git.gnome.org/browse/evince#commit=d1cef98aecbc490dbea72323e4e75af5fcc2f5d8
+ source = git+https://gitlab.gnome.org/GNOME/evince.git#commit=10da4bcec1cdd535a267e4b8e971668a47f0138b
md5sums = SKIP
pkgname = evince-no-gnome
diff --git a/PKGBUILD b/PKGBUILD
index 85c624ff0056..25bc3ecb1996 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Maintainer: Yiyao Yu <yyudevel at protonmail dot com>
+# Contributor: GordonGR <ntheo1979@gmail.com>
# Contributor: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani at gmail dot com>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=evince-no-gnome
_pkgname=evince
-pkgver=3.30.2
+pkgver=3.32.0
pkgrel=1
pkgdesc="GTK3 document viewer, complete features, no gnome dependencies"
url="https://wiki.gnome.org/Apps/Evince"
arch=('i686' 'x86_64')
license=('GPL')
depends=('dconf' 'gtk3' 'libgxps' 'libspectre' 'poppler-glib' 'djvulibre' 'gsettings-desktop-schemas' 'gspell' 'libarchive' 'gst-plugins-base-libs')
-makedepends=('itstool' 'texlive-bin' 'gobject-introspection' 'intltool' 'docbook-xsl' 'python' 'gtk-doc' 'gnome-common')
+makedepends=('itstool' 'texlive-bin' 'gobject-introspection' 'intltool' 'docbook-xsl' 'python' 'gtk-doc' 'gnome-common' 'appstream-glib')
optdepends=('texlive-bin: DVI support'
- 'gvfs: for session saving and bookmarking')
+ 'gvfs: for session saving and bookmarking')
provides=("${_pkgname}")
conflicts=("${_pkgname}" "evince-light")
options=('!emptydirs')
-_commit=d1cef98aecbc490dbea72323e4e75af5fcc2f5d8 # tags/3.30.2^0
-source=("git+https://git.gnome.org/browse/evince#commit=$_commit")
+_commit=10da4bcec1cdd535a267e4b8e971668a47f0138b # tags/3.32.0
+source=("git+https://gitlab.gnome.org/GNOME/evince.git#commit=$_commit")
md5sums=('SKIP')
pkgver() {
@@ -30,7 +31,7 @@ prepare() {
cd ${_pkgname}
NOCONFIGURE=1 ./autogen.sh
}
-
+
build() {
cd ${_pkgname}
BROWSER_PLUGIN_DIR=/usr/lib/epiphany/plugins \