summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:35:10 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:35:10 -0700
commit595fa2ac6fb6580c50537213459fc56f57c21fcb (patch)
treeda1e977d7e325081ddea777b0bc810f7fcd52b87
downloadaur-595fa2ac6fb6580c50537213459fc56f57c21fcb.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--0001-tiff-fix-compile-warning.patch33
-rw-r--r--PKGBUILD61
-rw-r--r--evince2-light.install13
-rw-r--r--kill-missing-gconf-complaints.patch12
-rw-r--r--libview-crash.patch32
-rw-r--r--update-poppler.patch58
7 files changed, 243 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..642790f1de6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = evince2-light
+ pkgdesc = Simply a document viewer (GTK2 version, GNOME free!)
+ pkgver = 2.32.0
+ pkgrel = 7
+ url = http://projects.gnome.org/evince/
+ install = evince2-light.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = gtk2
+ depends = poppler-glib
+ depends = libspectre
+ depends = djvulibre
+ depends = t1lib
+ depends = gsfonts
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ provides = evince
+ conflicts = evince
+ options = !libtool
+ source = http://ftp.gnome.org/pub/gnome/sources/evince/2.32/evince-2.32.0.tar.bz2
+ source = update-poppler.patch
+ source = libview-crash.patch
+ source = kill-missing-gconf-complaints.patch
+ source = 0001-tiff-fix-compile-warning.patch
+ md5sums = ebc3ce6df8dcbf29cb9492f8dd031319
+ md5sums = 10630dcef4486c00e58ef93963b4177f
+ md5sums = 98139149793acd30188e037780e9a2cf
+ md5sums = 0db697ba8cdca1deb889d36aaacf4f52
+ md5sums = 339d61e12fd953913e29c4ee8e908f54
+
+pkgname = evince2-light
+
diff --git a/0001-tiff-fix-compile-warning.patch b/0001-tiff-fix-compile-warning.patch
new file mode 100644
index 000000000000..ebc8976b3dca
--- /dev/null
+++ b/0001-tiff-fix-compile-warning.patch
@@ -0,0 +1,33 @@
+From 00b5e55c90477eeac02bec58f032cb6916a1eb5c Mon Sep 17 00:00:00 2001
+From: Hib Eris <hib@hiberis.nl>
+Date: Mon, 20 Feb 2012 21:36:16 +0100
+Subject: [PATCH] tiff: fix compile warning
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Backport
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ backend/tiff/tiff2ps.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/backend/tiff/tiff2ps.c b/backend/tiff/tiff2ps.c
+index c0dc0bf..fc63c2e 100644
+--- a/backend/tiff/tiff2ps.c
++++ b/backend/tiff/tiff2ps.c
+@@ -1127,8 +1127,8 @@ PS_Lvl2page(TIFF2PSContext* ctx, TIFF* tif, uint32 w, uint32 h)
+ }
+ buf_data = (unsigned char *)_TIFFmalloc(chunk_size);
+ if (!buf_data) {
+- TIFFError(ctx->filename, "Can't alloc %u bytes for %s.",
+- chunk_size, tiled_image ? "tiles" : "strips");
++ TIFFError(ctx->filename, "Can't alloc %u bytes for %s.",
++ (uint) chunk_size, tiled_image ? "tiles" : "strips");
+ return(FALSE);
+ }
+
+--
+1.7.6.5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2aa0453ea7d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: John Jenkins twodopeshaggy@gmail.com
+# Contributor: megadriver <megadriver at gmx dot com>
+# Contributor: Leonid.I
+# This is basically the old evince-gtk PKGBUILD by pizzapunk
+# This one DOES conflict with evince from [extra], on purpose :)
+
+pkgname=evince2-light
+pkgver=2.32.0
+pkgrel=7
+pkgdesc="Simply a document viewer (GTK2 version, GNOME free!)"
+arch=('i686' 'x86_64')
+url="http://projects.gnome.org/evince/"
+license=('GPL')
+depends=('gtk2' 'poppler-glib' 'libspectre' 'djvulibre' 't1lib' 'gsfonts' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('intltool')
+provides=('evince')
+conflicts=('evince')
+options=('!libtool')
+install=evince2-light.install
+source=("http://ftp.gnome.org/pub/gnome/sources/evince/2.32/evince-$pkgver.tar.bz2"
+ update-poppler.patch libview-crash.patch kill-missing-gconf-complaints.patch 0001-tiff-fix-compile-warning.patch)
+md5sums=('ebc3ce6df8dcbf29cb9492f8dd031319'
+ '10630dcef4486c00e58ef93963b4177f'
+ '98139149793acd30188e037780e9a2cf'
+ '0db697ba8cdca1deb889d36aaacf4f52'
+ "339d61e12fd953913e29c4ee8e908f54")
+
+build() {
+ cd "$srcdir"/evince-$pkgver
+
+ patch -Np1 -i "$srcdir/libview-crash.patch"
+ patch -Np1 -i "$srcdir/update-poppler.patch"
+ patch -Np1 -i "$srcdir/kill-missing-gconf-complaints.patch"
+ patch -Np1 -i "$srcdir/0001-tiff-fix-compile-warning.patch"
+ sed -i -e '63d' configure.ac
+ autoreconf -fi
+
+ # Don't depend on gnome-icon-theme
+ sed -i '/gnome-icon-theme/d' configure
+
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/evince \
+ --disable-static \
+ --disable-schemas-compile \
+ --disable-tests \
+ --disable-nautilus \
+ --disable-scrollkeeper \
+ --disable-help \
+ --enable-t1lib \
+ --enable-pixbuf \
+ --enable-impress \
+ --without-keyring \
+ --without-gconf
+ make LIBS=-lICE
+}
+
+package() {
+ cd "$srcdir"/evince-$pkgver
+ make DESTDIR="$pkgdir" install
+ rm -rf $pkgdir/usr/share/GConf
+}
diff --git a/evince2-light.install b/evince2-light.install
new file mode 100644
index 000000000000..813a842015ed
--- /dev/null
+++ b/evince2-light.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas &> /dev/null
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/kill-missing-gconf-complaints.patch b/kill-missing-gconf-complaints.patch
new file mode 100644
index 000000000000..39c64a6f7d64
--- /dev/null
+++ b/kill-missing-gconf-complaints.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac 2010-09-27 20:48:44.000000000 +0200
++++ b/configure.ac 2012-03-20 22:01:07.676509469 +0100
+@@ -11,6 +11,9 @@
+ # The evince API version
+ m4_define([ev_api_version], [2.32])
+
++# Kill gconf
++m4_pattern_allow([AM_GCONF_SOURCE_2],[GCONF_SCHEMAS_INSTALL])
++
+ # Libtool versioning. The backend and view libraries have separate versions.
+ # Before making a release, the libtool version should be modified.
+ # The string is of the form C:R:A.
diff --git a/libview-crash.patch b/libview-crash.patch
new file mode 100644
index 000000000000..65d07751fdd4
--- /dev/null
+++ b/libview-crash.patch
@@ -0,0 +1,32 @@
+commit a3b87cb28e46958b37e384a47604032ea0889807
+Author: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Sun Nov 21 12:27:21 2010 +0100
+
+ libview: Make sure we have a valid page range before getting/setting selection list
+
+ Fixes bug #630999.
+
+diff --git a/libview/ev-pixbuf-cache.c b/libview/ev-pixbuf-cache.c
+index 367f70d..ee68354 100644
+--- a/libview/ev-pixbuf-cache.c
++++ b/libview/ev-pixbuf-cache.c
+@@ -1035,6 +1035,9 @@ ev_pixbuf_cache_set_selection_list (EvPixbufCache *pixbuf_cache,
+ if (!EV_IS_SELECTION (pixbuf_cache->document))
+ return;
+
++ if (pixbuf_cache->start_page == -1 || pixbuf_cache->end_page == -1)
++ return;
++
+ /* We check each area to see what needs updating, and what needs freeing; */
+ page = pixbuf_cache->start_page - pixbuf_cache->preload_cache_size;
+ for (i = 0; i < pixbuf_cache->preload_cache_size; i++) {
+@@ -1114,6 +1117,9 @@ ev_pixbuf_cache_get_selection_list (EvPixbufCache *pixbuf_cache)
+
+ g_return_val_if_fail (EV_IS_PIXBUF_CACHE (pixbuf_cache), NULL);
+
++ if (pixbuf_cache->start_page == -1 || pixbuf_cache->end_page == -1)
++ return NULL;
++
+ /* We check each area to see what needs updating, and what needs freeing; */
+ page = pixbuf_cache->start_page - pixbuf_cache->preload_cache_size;
+ for (i = 0; i < pixbuf_cache->preload_cache_size; i++) {
diff --git a/update-poppler.patch b/update-poppler.patch
new file mode 100644
index 000000000000..29bcad6b948b
--- /dev/null
+++ b/update-poppler.patch
@@ -0,0 +1,58 @@
+From f77e6cf4fd7fef49ac91d8c62b6a9a993529adb8 Mon Sep 17 00:00:00 2001
+From: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Fri, 17 Sep 2010 11:21:16 +0000
+Subject: [pdf] Update to poppler api changes
+
+Linearized PopplerDocument property is now boolean rather than string.
+---
+diff --git a/backend/pdf/ev-poppler.cc b/backend/pdf/ev-poppler.cc
+index aa080e6..ced3ef7 100644
+--- a/backend/pdf/ev-poppler.cc
++++ b/backend/pdf/ev-poppler.cc
+@@ -722,6 +722,9 @@ pdf_document_get_info (EvDocument *document)
+ PopplerPermissions permissions;
+ EvPage *page;
+ char *metadata;
++#ifdef HAVE_POPPLER_DOCUMENT_IS_LINEARIZED
++ gboolean linearized;
++#endif
+
+ info = g_new0 (EvDocumentInfo, 1);
+
+@@ -758,7 +761,11 @@ pdf_document_get_info (EvDocument *document)
+ "producer", &(info->producer),
+ "creation-date", &(info->creation_date),
+ "mod-date", &(info->modified_date),
++#ifdef HAVE_POPPLER_DOCUMENT_IS_LINEARIZED
++ "linearized", &linearized,
++#else
+ "linearized", &(info->linearized),
++#endif
+ "metadata", &metadata,
+ NULL);
+
+@@ -864,6 +871,10 @@ pdf_document_get_info (EvDocument *document)
+ info->security = g_strdup (_("No"));
+ }
+
++#ifdef HAVE_POPPLER_DOCUMENT_IS_LINEARIZED
++ info->linearized = linearized ? g_strdup (_("Yes")) : g_strdup (_("No"));
++#endif
++
+ return info;
+ }
+
+diff --git a/configure.ac b/configure.ac
+index 0faa16e..9619349 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -512,6 +512,7 @@ if test "x$enable_pdf" = "xyes"; then
+ AC_CHECK_FUNCS(poppler_page_get_text_layout)
+ AC_CHECK_FUNCS(poppler_page_get_selected_text)
+ AC_CHECK_FUNCS(poppler_page_add_annot)
++ AC_CHECK_FUNCS(poppler_document_is_linearized)
+ LIBS=$evince_save_LIBS
+ PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)
+ if test x$enable_cairo_pdf = xyes; then
+--
+cgit v0.8.3.1