summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Shumate2020-06-27 15:14:07 -0500
committerScott Shumate2020-06-27 15:14:07 -0500
commit82e6ed5a0b4365d4942a3572779caa5d387b2f2a (patch)
treee9e05b4e64d55af85c8eaec8cd58057b1824084b
downloadaur-evjs.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..585c7b39e247
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = evjs
+ pkgdesc = Joystick auto-calibration and testing utility for evdev and joydev
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/shumatech/evjs
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ depends = ncurses
+ depends = sqlite3
+ provides = evjs
+ source = https://github.com/shumatech/evjs/archive/v0.1.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = evjs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bc2aa573e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20a62a18fb07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Scott Shumate <scott(at)shumatech(dot)com>
+pkgname=evjs
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Joystick auto-calibration and testing utility for evdev and joydev"
+arch=(x86_64)
+url="https://github.com/shumatech/evjs"
+license=('GPL')
+depends=('ncurses' 'sqlite3')
+provides=('evjs')
+makedepends=('autoconf')
+source=("https://github.com/shumatech/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
+ install -D -m 0644 -o root -g root evjs.rules ${pkgdir}/etc/udev/rules.d/99-evjs.rules
+}