summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorannguyenfoss2019-09-10 14:51:14 +0700
committerannguyenfoss2019-09-10 14:51:14 +0700
commit0d6100b21e2dc04842a7b0964208069f0953e75e (patch)
tree59f2bce220097195794a4a8fdcc9577bd88add1b
downloadaur-0d6100b21e2dc04842a7b0964208069f0953e75e.tar.gz
init repo, forked from evolus-pencil-git
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
-rw-r--r--pencil.desktop9
-rwxr-xr-xpencil.sh4
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab6375a796d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = evolus-pencil-devel-git
+ pkgdesc = An open-source GUI prototyping tool - Development branch, GitHub
+ pkgver = 1396.3ed2b8a
+ pkgrel = 1
+ url = http://pencil.evolus.vn/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = npm
+ depends = electron
+ provides = evolus-pencil-bin
+ provides = evolus-pencil-git
+ conflicts = evolus-pencil-bin
+ conflicts = evolus-pencil-git
+ replaces = evolus-pencil-git
+ source = pencil::git+https://github.com/evolus/pencil.git#branch=development
+ source = pencil.desktop
+ source = pencil.sh
+ md5sums = SKIP
+ md5sums = 66ca7e3cc83eb681ad89cb2ec80e76b6
+ md5sums = e72976807104a384ed291f239df2d77f
+
+pkgname = evolus-pencil-devel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..457f2fb22488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: An Nguyen (stk) <an@linux.com>
+# Original Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=evolus-pencil-devel-git
+pkgver=1396.3ed2b8a
+pkgrel=1
+pkgdesc="An open-source GUI prototyping tool - Development branch, GitHub"
+arch=('i686' 'x86_64')
+url="http://pencil.evolus.vn/"
+license=('GPL2')
+depends=('electron')
+makedepends=('git' 'npm')
+provides=('evolus-pencil-bin' 'evolus-pencil-git')
+conflicts=('evolus-pencil-bin' 'evolus-pencil-git')
+replaces=('evolus-pencil-git')
+source=("pencil::git+https://github.com/evolus/pencil.git#branch=development"
+ "pencil.desktop"
+ "pencil.sh")
+md5sums=('SKIP'
+ '66ca7e3cc83eb681ad89cb2ec80e76b6'
+ 'e72976807104a384ed291f239df2d77f')
+
+pkgver() {
+ cd "$srcdir/pencil"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "$srcdir/pencil"
+ npm install --cache "${srcdir}/npm-cache"
+}
+
+package() {
+ cd "$srcdir/pencil"
+
+ install -d -m755 "$pkgdir/usr/lib"
+ cp -r app "$pkgdir/usr/lib/pencil"
+
+ install -D -m755 "$srcdir/pencil.sh" "$pkgdir/usr/bin/pencil.sh"
+ install -D -m644 "$srcdir/pencil.desktop" "$pkgdir/usr/share/applications/pencil.desktop"
+ for ICON in build/icons/* ; do
+ install -D -m644 "$ICON" \
+ "$pkgdir"/usr/share/icons/hicolor/`basename $ICON .png`/apps/pencil.png
+ done
+}
+
diff --git a/pencil.desktop b/pencil.desktop
new file mode 100644
index 000000000000..4067e2c9ee3e
--- /dev/null
+++ b/pencil.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Pencil
+Comment=An open-source GUI prototyping tool that is available for ALL platforms.
+Exec="/usr/bin/pencil.sh"
+Terminal=false
+Type=Application
+Icon=pencil
+Categories=Graphics
+
diff --git a/pencil.sh b/pencil.sh
new file mode 100755
index 000000000000..08803a81868d
--- /dev/null
+++ b/pencil.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+
+exec /usr/bin/electron /usr/lib/pencil
+