summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Latifi2021-12-30 07:57:58 +0100
committerFlorian Latifi2021-12-30 07:57:58 +0100
commitcbbcf5c9632eb402d7f53d6bf7780b438df6f89a (patch)
treecd16a889e60cc9f622fe1c9e9ddbe0c6249bb88b
parentb6e70fd2368736ad4b8ef0f98a67cf5953332b2b (diff)
downloadaur-cbbcf5c9632eb402d7f53d6bf7780b438df6f89a.tar.gz
Update to 2.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--use-format-string.patch21
3 files changed, 7 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b380773ad69..d3f56e394afb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = evolution-decsync
pkgdesc = An Evolution plugin which synchronizes contacts and calendars using DecSync.
- pkgver = 2.0.0
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/39aldo39/Evolution-DecSync
arch = x86_64
@@ -14,9 +14,7 @@ pkgbase = evolution-decsync
depends = evolution-data-server
depends = evolution
depends = libdecsync
- source = https://github.com/39aldo39/Evolution-DecSync/archive/v2.0.0-evolution-3.40.tar.gz
- source = use-format-string.patch
- sha256sums = 8772a8fcaf07cffe15163cf4d0b598d2cb8806bea4ddaa9ddfe150771da1679b
- sha256sums = 4c2e04a0e2352f22197db66f416670c0eb3da44f4520195e660e804b820388fc
+ source = https://github.com/39aldo39/Evolution-DecSync/archive/v2.0.1-evolution-3.40.tar.gz
+ sha256sums = 1b97ca43abf423550f9fa7ff35cc17315461478c8c3920f90e20ed97e690fb37
pkgname = evolution-decsync
diff --git a/PKGBUILD b/PKGBUILD
index bd7b5b2c7a00..e7d75171f1b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Florian Latifi <mail@florian-latifi.at>
pkgname=evolution-decsync
-pkgver=2.0.0
-_pkgver=2.0.0-evolution-3.40
+pkgver=2.0.1
+_pkgver=2.0.1-evolution-3.40
pkgrel=1
pkgdesc="An Evolution plugin which synchronizes contacts and calendars using DecSync."
arch=(x86_64 i686 armv7h aarch64)
@@ -12,15 +12,8 @@ license=(LGPL)
url="https://github.com/39aldo39/Evolution-DecSync"
depends=(json-c evolution-data-server evolution libdecsync)
makedepends=(meson ninja)
-source=("https://github.com/39aldo39/Evolution-DecSync/archive/v${_pkgver}.tar.gz"
- "use-format-string.patch")
-sha256sums=('8772a8fcaf07cffe15163cf4d0b598d2cb8806bea4ddaa9ddfe150771da1679b'
- '4c2e04a0e2352f22197db66f416670c0eb3da44f4520195e660e804b820388fc')
-
-prepare() {
- cd "Evolution-DecSync-${_pkgver}"
- patch --forward --strip=1 --input="${srcdir}/use-format-string.patch"
-}
+source=("https://github.com/39aldo39/Evolution-DecSync/archive/v${_pkgver}.tar.gz")
+sha256sums=('1b97ca43abf423550f9fa7ff35cc17315461478c8c3920f90e20ed97e690fb37')
build() {
cd "Evolution-DecSync-${_pkgver}"
diff --git a/use-format-string.patch b/use-format-string.patch
deleted file mode 100644
index d7f1a9609d97..000000000000
--- a/use-format-string.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 0594a82b134aa133e6c60b1a88cea94063179e24 Mon Sep 17 00:00:00 2001
-From: Aldo Gunsing <dev@aldogunsing.nl>
-Date: Tue, 19 Oct 2021 21:05:09 +0200
-Subject: [PATCH] Use format string (#36)
-
----
- src/modules/utils/decsync.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/modules/utils/decsync.c b/src/modules/utils/decsync.c
-index 40c538e..755aeaf 100644
---- a/src/modules/utils/decsync.c
-+++ b/src/modules/utils/decsync.c
-@@ -175,6 +175,7 @@ config_decsync_update_combo_box (Context *context)
- GTK_DIALOG_DESTROY_WITH_PARENT,
- GTK_MESSAGE_WARNING,
- GTK_BUTTONS_OK,
-+ "%s",
- error_string);
- title = _("DecSync");
- gtk_window_set_title (GTK_WINDOW (dialog), title);