summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hacohen2020-08-20 13:45:24 +0300
committerTom Hacohen2020-08-20 13:45:24 +0300
commit9aab25f75e2d8bbc946deedb546b6f94e2f01744 (patch)
treec86db6224bf6330b59ff521ac6cfde33792fb062
downloadaur-9aab25f75e2d8bbc946deedb546b6f94e2f01744.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5de7644099a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = evolution-etesync-git
+ pkgdesc = EteSync (end-to-end encrypted sync) plugin for Evolution
+ pkgver = r55.833f264
+ pkgrel = 1
+ url = https://gitlab.gnome.org/nourmat/evolution-etesync/
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ depends = libgee
+ depends = json-glib
+ depends = evolution-data-server
+ depends = evolution
+ depends = etesync
+ source = evolution-etesync::git+https://gitlab.gnome.org/nourmat/evolution-etesync.git
+ sha512sums = SKIP
+
+pkgname = evolution-etesync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d7d2783acf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tom Hacohen <tom@stosb.com>
+
+pkgname=evolution-etesync-git
+_pkgname=evolution-etesync
+pkgver=r55.833f264
+pkgrel=1
+pkgdesc="EteSync (end-to-end encrypted sync) plugin for Evolution"
+arch=(x86_64)
+url="https://gitlab.gnome.org/nourmat/evolution-etesync/"
+license=('LGPL')
+depends=(libgee json-glib evolution-data-server evolution etesync)
+makedepends=(cmake meson ninja vala git)
+makedepends=('intltool')
+source=("${_pkgname}::git+https://gitlab.gnome.org/nourmat/evolution-etesync.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ cd build
+ make DESTDIR="${pkgdir}" install
+}