summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-06-09 21:19:05 -0400
committerBuildTools2015-06-09 21:19:05 -0400
commit0141d449a78daaf9b81d9bc9c17f1d2fe7d92da0 (patch)
treee3ab4e49427317b4052b3d6f0804971f19964e58
downloadaur-0141d449a78daaf9b81d9bc9c17f1d2fe7d92da0.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD41
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3322ce7bcbd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 1 14:40:38 UTC 2015
+pkgbase = evolution-ews-git
+ pkgdesc = MS Exchange integration through Exchange Web Services
+ pkgver = 3.17.2.r1.g93fd330
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Evolution/EWS
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = intltool
+ depends = libmspack
+ depends = evolution-git
+ provides = evolution-ews
+ conflicts = evolution-ews
+ replaces = evolution-ews
+ options = !emptydirs
+ source = git://git.gnome.org/evolution-ews
+ sha256sums = SKIP
+
+pkgname = evolution-ews-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..b92352b7ab63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Tom Moore <tmoore01 (at) gmail (dot) com>
+
+_pkgname=evolution-ews
+pkgname=$_pkgname-git
+pkgver=3.17.2.r1.g93fd330
+pkgrel=1
+pkgdesc="MS Exchange integration through Exchange Web Services"
+arch=('i686' 'x86_64')
+license=('LGPL2.1')
+url="https://wiki.gnome.org/Apps/Evolution/EWS"
+depends=('libmspack' 'evolution-git')
+makedepends=('intltool')
+options=('!emptydirs')
+conflicts=('evolution-ews')
+replaces=('evolution-ews')
+provides=('evolution-ews')
+source=(git://git.gnome.org/evolution-ews)
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/$_pkgname
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/evolution --disable-static
+ make
+}
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --long | sed 's/^EVOLUTION_EWS_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+}
+
+package() {
+ cd $srcdir/_$pkgname
+ make DESTDIR="$pkgdir" install
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ make DESTDIR="${pkgdir}" install
+ cd "$srcdir"
+}