summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilvio Fricke2018-08-06 08:33:16 +0200
committerSilvio Fricke2018-08-06 08:36:09 +0200
commit9d6065de39f8673ad5dc136001f802f33429aa91 (patch)
treed862ea003d388c5e0d88445a2ee5efb1f9e04223
parent0141d449a78daaf9b81d9bc9c17f1d2fe7d92da0 (diff)
downloadaur-9d6065de39f8673ad5dc136001f802f33429aa91.tar.gz
update to 3.29.90
rework complete recipe Signed-off-by: Silvio Fricke <silvio.fricke@softing.com>
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD36
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3322ce7bcbd4..b954aeb58dfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by makepkg 4.2.1
-# Mon Jun 1 14:40:38 UTC 2015
pkgbase = evolution-ews-git
pkgdesc = MS Exchange integration through Exchange Web Services
- pkgver = 3.17.2.r1.g93fd330
+ pkgver = 3.29.90.r001.g2a6cd383
pkgrel = 1
url = https://wiki.gnome.org/Apps/Evolution/EWS
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b92352b7ab63..362e607ec2d5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Tom Moore <tmoore01 (at) gmail (dot) com>
+# Maintainer: Silvio Fricke <silvio.fricke@gmail.com>
+# Contributor: Tom Moore <tmoore01 (at) gmail (dot) com>
_pkgname=evolution-ews
pkgname=$_pkgname-git
-pkgver=3.17.2.r1.g93fd330
+pkgver=3.29.90.r001.g2a6cd383
pkgrel=1
pkgdesc="MS Exchange integration through Exchange Web Services"
arch=('i686' 'x86_64')
@@ -17,25 +18,26 @@ provides=('evolution-ews')
source=(git://git.gnome.org/evolution-ews)
sha256sums=('SKIP')
-build() {
- cd $srcdir/$_pkgname
- ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/evolution --disable-static
- make
-}
-
pkgver() {
- cd $srcdir/$_pkgname
- git describe --long | sed 's/^EVOLUTION_EWS_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+ cd $srcdir/$_pkgname
+ git describe --long | awk -F '-' '/-/{ printf "%s.r%3.3d.%s\n", $1, $2, $3 }'
}
-package() {
- cd $srcdir/_$pkgname
- make DESTDIR="$pkgdir" install
+build() {
+ cd $srcdir/$_pkgname
+
+ [ ! -d build ] && mkdir build
+ cd build
+
+ cmake .. -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBEXEC_INSTALL_DIR=/usr/lib/evolution \
+ -DSYSCONF_INSTALL_DIR=/etc
+ ninja
}
package() {
- cd $srcdir/$_pkgname
- make DESTDIR="${pkgdir}" install
- cd "$srcdir"
+ cd $srcdir/$_pkgname/build
+ DESTDIR="$pkgdir" ninja install
}
+