summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2018-06-02 17:13:01 -0700
committerShadowKyogre2018-06-02 17:13:01 -0700
commit6505903a4722711be00ce93a2044b837df66721f (patch)
tree52c70dbe38f2d27355e4eda49293dd640a77300d
parente62db380ac04b3ffd59e6db99cdecaa7a4cd7d63 (diff)
downloadaur-6505903a4722711be00ce93a2044b837df66721f.tar.gz
Update to version 0.7.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--fix_bool_cast.patch33
3 files changed, 12 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee82b4f46bd6..82fb5f557cd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
# Generated by mksrcinfo v8
-# Sun Jul 31 21:06:14 UTC 2016
+# Sun Jun 3 00:12:55 UTC 2018
pkgbase = evolvotron
pkgdesc = An interactive generative art application
- pkgver = 0.6.3
- pkgrel = 2
+ pkgver = 0.7.1
+ pkgrel = 1
url = http://www.bottlenose.demon.co.uk/share/evolvotron/
arch = i686
arch = x86_64
license = GPL
makedepends = boost
makedepends = gendesk
- depends = qt4
+ depends = qt5-base
depends = boost-libs
- source = http://downloads.sourceforge.net/evolvotron/evolvotron-0.6.3.tar.gz
- source = fix_bool_cast.patch
+ source = http://downloads.sourceforge.net/evolvotron/evolvotron-0.7.1.tar.gz
source = evolvotron.png
- md5sums = d36afd3d8e4d89418fffd963d204d5a8
- md5sums = 9abc069adfa6ee50b8c206fef046e2b4
+ md5sums = 8fc731f03b115f8ecc5891a93f3dd518
md5sums = 0302f0dde78ced8f177276ce96ddab5e
pkgname = evolvotron
diff --git a/PKGBUILD b/PKGBUILD
index 222af2215b02..8a48d1d77787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,27 @@
# Contributor: Bram Schoenmakers <me@bramschoenmakers.nl>
pkgname=evolvotron
-pkgver=0.6.3
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc="An interactive generative art application"
arch=('i686' 'x86_64')
url="http://www.bottlenose.demon.co.uk/share/evolvotron/"
license=('GPL')
-depends=('qt4' 'boost-libs')
+depends=('qt5-base' 'boost-libs')
makedepends=('boost' 'gendesk')
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
-"fix_bool_cast.patch"
"evolvotron.png"
)
prepare() {
gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
cd "$srcdir/$pkgname"
- patch -Np1 -i "${srcdir}/fix_bool_cast.patch"
}
build() {
cd "$srcdir/$pkgname"
- QTDIR=/usr/bin ./configure
- make
+ qmake-qt5 "VERSION_NUMBER=$(./VERSION)" main.pro
+ make -j 4
}
package() {
@@ -42,6 +40,5 @@ package() {
install -Dm644 "${srcdir}/${pkgname}.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/${pkgname}.png"
}
# vim:syntax=sh
-md5sums=('d36afd3d8e4d89418fffd963d204d5a8'
- '9abc069adfa6ee50b8c206fef046e2b4'
+md5sums=('8fc731f03b115f8ecc5891a93f3dd518'
'0302f0dde78ced8f177276ce96ddab5e')
diff --git a/fix_bool_cast.patch b/fix_bool_cast.patch
deleted file mode 100644
index 5613b76468f5..000000000000
--- a/fix_bool_cast.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Only in evolvotron.mod/evolvotron: evolvotron
-Only in evolvotron.mod/evolvotron: evolvotron.gch
-Only in evolvotron.mod/evolvotron: Makefile
-Only in evolvotron.mod/evolvotron: moc
-Only in evolvotron.mod/evolvotron_mutate: evolvotron_mutate
-Only in evolvotron.mod/evolvotron_mutate: evolvotron_mutate.gch
-Only in evolvotron.mod/evolvotron_mutate: Makefile
-Only in evolvotron.mod/evolvotron_mutate: moc
-Only in evolvotron.mod/evolvotron_render: evolvotron_render
-Only in evolvotron.mod/evolvotron_render: evolvotron_render.gch
-Only in evolvotron.mod/evolvotron_render: Makefile
-Only in evolvotron.mod/evolvotron_render: moc
-Only in evolvotron.mod/libevolvotron: evolvotron.gch
-Only in evolvotron.mod/libevolvotron: libevolvotron.a
-Only in evolvotron.mod/libevolvotron: Makefile
-Only in evolvotron.mod/libevolvotron: moc
-diff -aur evolvotron/libevolvotron/mutatable_image_computer.h evolvotron.mod/libevolvotron/mutatable_image_computer.h
---- evolvotron/libevolvotron/mutatable_image_computer.h 2013-01-26 04:48:42.000000000 -0800
-+++ evolvotron.mod/libevolvotron/mutatable_image_computer.h 2016-07-08 19:33:36.357723781 -0700
-@@ -193,7 +193,7 @@
- //! Indicate whether computation us taking place (only intended for counting outstanding threads).
- bool active() const
- {
-- return _task;
-+ return _task != NULL;
- }
- };
-
-Only in evolvotron.mod/libfunction: function.gch
-Only in evolvotron.mod/libfunction: libfunction.a
-Only in evolvotron.mod/libfunction: Makefile
-Only in evolvotron.mod/libfunction: moc
-Only in evolvotron.mod: Makefile