summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Appelman2020-03-20 23:39:12 +0100
committerRobin Appelman2020-03-20 23:39:12 +0100
commitc675f5a8f931e6594e82526b73420e6fa09778ac (patch)
treee0fbfe6d03126c6b291c097e860928a264d4626b
downloadaur-c675f5a8f931e6594e82526b73420e6fa09778ac.tar.gz
initial package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8248b778e12c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = evtype
+ pkgdesc = Virtual typing using evdev
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/icewind1991/evtype
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = evtype-0.1.0.tar.gz::https://github.com/icewind1991/evtype/archive/v0.1.0.tar.gz
+ sha512sums = d320118d4fd692f622476a27d1b654e9a9a92b9e30b567c64b8634ae6b2880526e156d300848b59cded2b00509c9c3c380cc57022b80b9be09f21d88ba5f07d9
+
+pkgname = evtype
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3be3a0426e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+evtype*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36c048a6ea9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Robin Appelman <robin@icewind.nl>
+
+pkgname=evtype
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Virtual typing using evdev"
+url="https://github.com/icewind1991/evtype"
+makedepends=('cargo')
+arch=('i686' 'x86_64')
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/icewind1991/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('d320118d4fd692f622476a27d1b654e9a9a92b9e30b567c64b8634ae6b2880526e156d300848b59cded2b00509c9c3c380cc57022b80b9be09f21d88ba5f07d9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "target/release/${pkgname}_daemon" "$pkgdir/usr/bin/$pkgname_daemon"
+ install -Dm644 "$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
+}
+