summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2015-04-01 09:55:19 -0500
committerDoug Newgard2015-06-08 13:45:26 -0500
commit0162bd170cabfbcc675c777bc3402b049bec7537 (patch)
treee89a19780d106452335214c11bf0e51db95406d7
parentca68e06ec9973a0eb214b202d79d9e3280a5e15b (diff)
downloadaur-0162bd170cabfbcc675c777bc3402b049bec7537.tar.gz
Get rid of minibrowser
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8264395dc7c8..b473de031aa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ewebkit
pkgdesc = WebKit ported to the Enlightenment Foundation Libraries
pkgver = 1.11.0
- pkgrel = 1
+ pkgrel = 2
url = http://trac.webkit.org/wiki/EFLWebKit
arch = i686
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = ewebkit
makedepends = python2
makedepends = ruby
makedepends = gperf
- makedepends = chrpath
depends = atk
- depends = elementary
+ depends = cairo
+ depends = efl
depends = enchant
depends = harfbuzz-icu
depends = libsoup
diff --git a/PKGBUILD b/PKGBUILD
index 749e92c579f5..7673aa8daa40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=ewebkit
pkgver=1.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="WebKit ported to the Enlightenment Foundation Libraries"
arch=('i686' 'x86_64')
url="http://trac.webkit.org/wiki/EFLWebKit"
license=('LGPL2' 'LGPL2.1' 'BSD')
-depends=('atk' 'elementary' 'enchant' 'harfbuzz-icu' 'libsoup' 'libxslt')
-makedepends=('cmake' 'perl' 'python2' 'ruby' 'gperf' 'chrpath')
+depends=('atk' 'cairo' 'efl' 'enchant' 'harfbuzz-icu' 'libsoup' 'libxslt')
+makedepends=('cmake' 'perl' 'python2' 'ruby' 'gperf')
source=("http://download.enlightenment.org/rel/libs/webkit-efl/$pkgname-$pkgver.tar.xz")
sha256sums=('d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7')
@@ -21,7 +21,8 @@ build() {
export CXXFLAGS="$CXXFLAGS -Wno-deprecated-declarations"
cmake . \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_TOOLS=OFF
make
}
@@ -31,9 +32,6 @@ package() {
make DESTDIR="$pkgdir" install
- chrpath --delete bin/MiniBrowser
- install -m755 bin/MiniBrowser "$pkgdir/usr/bin/MiniBrowser-ewk"
-
# install license files
install -d "$pkgdir/usr/share/licenses/$pkgname/"
install -m644 -t "$pkgdir/usr/share/licenses/$pkgname/" Source/WebCore/LICENSE-{APPLE,LGPL-2}