summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-05-30 08:41:17 -0500
committerDoug Newgard2013-05-30 08:41:17 -0500
commit7393dc8d34e296dfbce5691ced6907c31383c9e5 (patch)
treefab408254fc382970d2e2e12b878116df4e168d1
parent0fcbe5795917a4641b1f8b56a70959710eec9f23 (diff)
downloadaur-7393dc8d34e296dfbce5691ced6907c31383c9e5.tar.gz
Remove patch, fixed upstream
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--uninitialized_pointer.patch22
3 files changed, 0 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd27b1732196..3cf52d1a8d9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,8 +26,6 @@ pkgbase = ewebkit-svn
depends = libsoup
depends = libxslt
depends = libxt
- source = uninitialized_pointer.patch
- md5sums = 64f29e03a269cadeaca651f4f4746200
pkgname = ewebkit-svn
diff --git a/PKGBUILD b/PKGBUILD
index 263aefec6c72..745c23a5fef3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,6 @@ license=('LGPL2' 'LGPL2.1' 'BSD')
depends=('atk' 'cairo' 'edje' 'eeze' 'efreet' 'e_dbus' 'enchant' 'libtiff'
'gst-plugins-base-libs' 'libsoup' 'libxslt' 'libxt')
makedepends=('cmake' 'subversion' 'perl' 'python2' 'ruby' 'gperf')
-source=('uninitialized_pointer.patch')
-md5sums=('64f29e03a269cadeaca651f4f4746200')
if [[ -d "$SRCDEST/$_pkgname/.svn" ]]; then
source+=("$_pkgname::svn+$_svnurl")
md5sums+=("SKIP")
@@ -44,10 +42,6 @@ prepare() {
rm -rf "$srcdir/$_pkgname"
cp -a "$SRCDEST/$_pkgname" "$srcdir/$_pkgname"
fi
-
-# Initialize pointer to avoid build error
- cd $srcdir/$_pkgname
- patch -Np0 < ../uninitialized_pointer.patch
}
build() {
diff --git a/uninitialized_pointer.patch b/uninitialized_pointer.patch
deleted file mode 100644
index 574914469944..000000000000
--- a/uninitialized_pointer.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: Source/WebCore/inspector/InspectorDOMStorageAgent.cpp
-===================================================================
---- Source/WebCore/inspector/InspectorDOMStorageAgent.cpp (revision 147898)
-+++ Source/WebCore/inspector/InspectorDOMStorageAgent.cpp (working copy)
-@@ -152,7 +152,7 @@
-
- void InspectorDOMStorageAgent::setDOMStorageItem(ErrorString* errorString, const RefPtr<InspectorObject>& storageId, const String& key, const String& value)
- {
-- Frame* frame;
-+ Frame* frame = NULL;
- RefPtr<StorageArea> storageArea = findStorageArea(0, storageId, frame);
- if (!storageArea) {
- *errorString = "Storage not found";
-@@ -166,7 +166,7 @@
-
- void InspectorDOMStorageAgent::removeDOMStorageItem(ErrorString* errorString, const RefPtr<InspectorObject>& storageId, const String& key)
- {
-- Frame* frame;
-+ Frame* frame = NULL;
- RefPtr<StorageArea> storageArea = findStorageArea(0, storageId, frame);
- if (!storageArea) {
- *errorString = "Storage not found";