summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2012-12-02 02:51:37 -0600
committerDoug Newgard2012-12-02 02:51:37 -0600
commita8bf00bc7612720cfcdb4f921569f37227f4d5ce (patch)
tree0e448e668f134744ab6724b3a3088f723a5ea64e
parentb1de74f2ef9cd1e6d94adf9b494ae9225ad9a7c8 (diff)
downloadaur-a8bf00bc7612720cfcdb4f921569f37227f4d5ce.tar.gz
Move gperf to makedeps, add options for building webkit and/or webkit2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94ca15791fe4..409de69e67a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ewebkit-svn
pkgdesc = WebKit ported to the Enlightenment Foundation Libraries
- pkgver = 136302
+ pkgver = 136318
pkgrel = 1
url = http://trac.webkit.org/wiki/EFLWebKit
arch = i686
@@ -13,17 +13,17 @@ pkgbase = ewebkit-svn
makedepends = perl
makedepends = python2
makedepends = ruby
+ makedepends = gperf
depends = atk
depends = cairo
depends = elementary<1.8
depends = enchant
depends = gstreamer0.10-base
- depends = gperf
depends = libtiff
depends = libsoup
depends = libxslt
depends = libxt
- depends = sqlite3
+ depends = sqlite
pkgname = ewebkit-svn
diff --git a/PKGBUILD b/PKGBUILD
index 002f891b93fa..d65fc75f74d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=ewebkit-svn
-pkgver=136302
+pkgver=136318
pkgrel=1
pkgdesc="WebKit ported to the Enlightenment Foundation Libraries"
arch=('i686' 'x86_64')
url="http://trac.webkit.org/wiki/EFLWebKit"
license=('LGPL2' 'LGPL2.1' 'BSD')
depends=('atk' 'cairo' 'elementary<1.8' 'enchant' 'gstreamer0.10-base'
- 'gperf' 'libtiff' 'libsoup' 'libxslt' 'libxt' 'sqlite3')
-makedepends=('cmake' 'subversion' 'perl' 'python2' 'ruby')
+ 'libtiff' 'libsoup' 'libxslt' 'libxt' 'sqlite')
+makedepends=('cmake' 'subversion' 'perl' 'python2' 'ruby' 'gperf')
_svntrunk=https://svn.webkit.org/repository/webkit/trunk
_svnmod=Webkit
@@ -42,7 +42,9 @@ build() {
-DPORT=Efl \
-DSHARED_CORE=OFF \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_WEBKIT=ON \
+ -DENABLE_WEBKIT2=ON
make
}