summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-05-08 20:55:50 -0500
committerDoug Newgard2013-05-08 20:55:50 -0500
commitc246d627495b5ff9f1255eb39bd75fed49abe286 (patch)
tree93793c7ff27420f2808043ac2ee87068fea96b9d
parent3b38a0c8271b239b46f242ded15c86a396b6a3f1 (diff)
downloadaur-c246d627495b5ff9f1255eb39bd75fed49abe286.tar.gz
Pacman 4.1.1 also copies instead of exports to make the build dir
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23eccf41cc97..e2ed4abe34ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,18 +22,17 @@ fi
pkgver() {
if [[ -d "$SRCDEST/$_pkgname/.svn" ]]; then
- svnversion "$SRCDEST/$_pkgname" | sed 's/P$//'
+ svnversion "$srcdir/$_pkgname" | sed 's/P$//'
else
LC_ALL=C svn info "$_svnurl" | awk '/Revision/ {print $2}'
fi
}
prepare() {
- cd "$SRCDEST"
-
- if [[ ! -d "$_pkgname/.svn" ]]; then
+ if [[ ! -d "$SRCDEST/$_pkgname/.svn" ]]; then
# if this is the first run, checkout only what we need from the repo
msg2 "Cloning $_pkgname svn repo..."
+ cd "$SRCDEST"
mkdir -p "$_pkgname/.makepkg"
svn co --depth immediates --config-dir "$_pkgname/.makepkg" -r "$pkgver" "$_svnurl" "$_pkgname"
cd "$_pkgname"
@@ -43,7 +42,7 @@ prepare() {
# and create a working copy
msg2 "Creating working copy of $_pkgname svn repo..."
rm -rf "$srcdir/$_pkgname"
- svn export "$SRCDEST/$_pkgname" "$srcdir/$_pkgname"
+ cp -a "$SRCDEST/$_pkgname" "$srcdir/$_pkgname"
fi
# Initialize pointer to avoid build error