summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-06-23 11:52:44 -0500
committerDoug Newgard2013-06-23 11:52:44 -0500
commitdaa485a26d1bc89ec87136e97b875e604b07e3d5 (patch)
tree507aaad8118b38f0df3c537f6d220194b4ab7b92
parent62fc301e5ed0686143e8828ffb4543423e57dab1 (diff)
downloadaur-daa485a26d1bc89ec87136e97b875e604b07e3d5.tar.gz
Add harfbuzz-icu dep; it's needed but won't build until they update the build system
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce3bb44517cd..4ec85e59fde0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,6 +26,7 @@ pkgbase = ewebkit-svn
depends = libsoup
depends = libxslt
depends = libxt
+ depends = harfbuzz-icu
pkgname = ewebkit-svn
diff --git a/PKGBUILD b/PKGBUILD
index 266ea6f2ad5e..91bbc0d34455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=ewebkit-svn
-_pkgname=ewebkit
+_pkgname=${pkgname%-*}
pkgver=151620
pkgrel=1
pkgdesc="WebKit ported to the Enlightenment Foundation Libraries"
@@ -11,7 +11,7 @@ url="http://trac.webkit.org/wiki/EFLWebKit"
_svnurl="https://svn.webkit.org/repository/webkit/trunk"
license=('LGPL2' 'LGPL2.1' 'BSD')
depends=('atk' 'cairo' 'edje' 'eeze' 'efreet' 'e_dbus' 'enchant' 'libtiff'
- 'gst-plugins-base-libs' 'libsoup' 'libxslt' 'libxt')
+ 'gst-plugins-base-libs' 'libsoup' 'libxslt' 'libxt' 'harfbuzz-icu')
makedepends=('cmake' 'subversion' 'perl' 'python2' 'ruby' 'gperf')
if [[ -d "$SRCDEST/$_pkgname/.svn" ]]; then
source+=("$_pkgname::svn+$_svnurl")