summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2015-04-23 11:15:59 -0500
committerDoug Newgard2015-06-08 13:52:47 -0500
commit7890234a7963c3113b3bce9072ef72c331947fc3 (patch)
tree3f01015552313baf3756ecde3bcd45b181acfb88
parent185c2e300cc596e235f406ef628acb306ed8cf4d (diff)
downloadaur-7890234a7963c3113b3bce9072ef72c331947fc3.tar.gz
Apply acutal fixes for build problems instead of hacking around them
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--fix_gio-unix.patch36
-rw-r--r--fix_libXext_linking.patch12
4 files changed, 66 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4828b6cf3504..d78a670ac20c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ewebkit-svn
pkgdesc = WebKit ported to the Enlightenment Foundation Libraries - Development version
- pkgver = 1.11.0.r182891
+ pkgver = 1.11.0.r183168
pkgrel = 1
url = http://trac.webkit.org/wiki/EFLWebKit
arch = i686
@@ -22,12 +22,16 @@ pkgbase = ewebkit-svn
depends = geoclue2
depends = harfbuzz-icu
depends = libxslt
- provides = ewebkit=1.11.0.r182891
+ provides = ewebkit=1.11.0.r183168
conflicts = ewebkit
source = ewebkit-svn/Source::svn+https://svn.webkit.org/repository/webkit/trunk/Source
source = ewebkit-svn/Tools::svn+https://svn.webkit.org/repository/webkit/trunk/Tools
+ source = fix_gio-unix.patch
+ source = fix_libXext_linking.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 0b302a01aad0287a5240cc60b06e01880db960dc67b689c74ecb1ab571b8d423
+ sha256sums = cbed18fde023d83cf810a31c6b77aab2247d78481cbbd264144f6bf5f6e5126c
pkgname = ewebkit-svn
diff --git a/PKGBUILD b/PKGBUILD
index 4763ccc475b9..6220274ad8f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=ewebkit
pkgname=$_pkgname-svn
-pkgver=1.11.0.r182891
+pkgver=1.11.0.r183168
pkgrel=1
pkgdesc="WebKit ported to the Enlightenment Foundation Libraries - Development version"
arch=('i686' 'x86_64')
@@ -14,9 +14,13 @@ makedepends=('cmake' 'subversion' 'perl' 'python2' 'ruby' 'gperf')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("$pkgname/Source::svn+https://svn.webkit.org/repository/webkit/trunk/Source"
- "$pkgname/Tools::svn+https://svn.webkit.org/repository/webkit/trunk/Tools")
+ "$pkgname/Tools::svn+https://svn.webkit.org/repository/webkit/trunk/Tools"
+ 'fix_gio-unix.patch'
+ 'fix_libXext_linking.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '0b302a01aad0287a5240cc60b06e01880db960dc67b689c74ecb1ab571b8d423'
+ 'cbed18fde023d83cf810a31c6b77aab2247d78481cbbd264144f6bf5f6e5126c')
pkgver() {
cd Source/cmake
@@ -32,8 +36,11 @@ prepare() {
# Turn off -Werror, causes too many build failures for things we don't care about
sed -i '/-Werror/d' Source/cmake/WebKitHelpers.cmake
-# Don't need this, and it's causing build error for some reason
- sed -i '/XSetExtensionErrorHandler/d' Source/WebKit2/WebProcess/efl/WebProcessMainEfl.cpp
+# Fix gio-unix cflag detection
+ patch -Np0 -i fix_gio-unix.patch
+
+# Let the linker find libXext for WebKit2
+ patch -Np0 -i fix_libXext_linking.patch
# Make sure Tools is at the same rev as Source
svn update --revision ${pkgver#*.r} Tools
@@ -53,10 +60,6 @@ prepare() {
}
build() {
-# Make it so geoclue support can find glib2
- export CFLAGS="$CFLAGS $(pkg-config --cflags gio-2.0)"
- export CXXFLAGS="$CXXFLAGS $(pkg-config --cflags gio-2.0)"
-
cmake . \
-DPORT=Efl \
-DCMAKE_INSTALL_PREFIX=/usr \
diff --git a/fix_gio-unix.patch b/fix_gio-unix.patch
new file mode 100644
index 000000000000..4060b14e684b
--- /dev/null
+++ b/fix_gio-unix.patch
@@ -0,0 +1,36 @@
+Index: cmake/OptionsEfl.cmake
+===================================================================
+--- Source/cmake/OptionsEfl.cmake (revision 183155)
++++ Source/cmake/OptionsEfl.cmake (working copy)
+@@ -176,15 +176,6 @@
+ find_package(Eo ${EFL_REQUIRED_VERSION} REQUIRED CONFIG)
+ find_package(Evas ${EFL_REQUIRED_VERSION} REQUIRED CONFIG)
+
+-find_package(Freetype2 2.4.2 REQUIRED)
+-find_package(GLIB 2.38.0 REQUIRED COMPONENTS ${GLIB_COMPONENTS})
+-find_package(HarfBuzz 0.9.2 REQUIRED)
+-find_package(LibSoup 2.42.0 REQUIRED)
+-
+-if (ENABLE_BATTERY_STATUS)
+- find_package(Eldbus ${EFL_REQUIRED_VERSION} CONFIG)
+-endif ()
+-
+ if (ENABLE_GEOLOCATION)
+ list(APPEND GLIB_COMPONENTS gio-unix)
+ find_package(GeoClue2 2.1.5)
+@@ -196,6 +187,15 @@
+ endif ()
+ endif ()
+
++find_package(Freetype2 2.4.2 REQUIRED)
++find_package(GLIB 2.38.0 REQUIRED COMPONENTS ${GLIB_COMPONENTS})
++find_package(HarfBuzz 0.9.2 REQUIRED)
++find_package(LibSoup 2.42.0 REQUIRED)
++
++if (ENABLE_BATTERY_STATUS)
++ find_package(Eldbus ${EFL_REQUIRED_VERSION} CONFIG)
++endif ()
++
+ if (ENABLE_MEDIA_STREAM)
+ find_package(OpenWebRTC)
+ if (OPENWEBRTC_FOUND)
diff --git a/fix_libXext_linking.patch b/fix_libXext_linking.patch
new file mode 100644
index 000000000000..23de2dfb2a71
--- /dev/null
+++ b/fix_libXext_linking.patch
@@ -0,0 +1,12 @@
+Index: WebKit2/PlatformEfl.cmake
+===================================================================
+--- Source/WebKit2/PlatformEfl.cmake (revision 183168)
++++ Source/WebKit2/PlatformEfl.cmake (working copy)
+@@ -346,6 +346,7 @@
+ )
+ list(APPEND WebKit2_LIBRARIES
+ ${ECORE_X_LIBRARIES}
++ ${X11_Xext_LIB}
+ )
+ endif ()
+