summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtifChy2021-08-31 01:38:03 +0600
committerAtifChy2021-08-31 01:38:03 +0600
commit02f530ae2647f3979b3f51e20a45725c15f61ffe (patch)
treef4719aa9552fa25bd1961ee034a7a0432e317870
parent3c78f9159b367a785dcf710962782f48e1b7a3d4 (diff)
downloadaur-02f530ae2647f3979b3f51e20a45725c15f61ffe.tar.gz
added a post install command
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD16
-rw-r--r--eww.install11
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf4e7f9b9b5c..d598b045937e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = eww-git
pkgver = 0.1.0.r164.g70285e0
pkgrel = 1
url = https://github.com/elkowar/eww
+ install = eww.install
arch = any
license = MIT
makedepends = rustup
diff --git a/PKGBUILD b/PKGBUILD
index 1fc05724094a..db0c649a92e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=eww-git
_pkgname=eww
pkgver=0.1.0.r164.g70285e0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="ElKowar's wacky widgets"
arch=('any')
@@ -18,7 +18,7 @@ conflicts=("eww")
replaces=()
backup=()
options=()
-install=
+install="${_pkgname}.install"
changelog=
source=("git+https://github.com/elkowar/eww")
noextract=()
@@ -39,19 +39,9 @@ build() {
package() {
cd "$_pkgname"
- install -Dm755 target/release/eww "${pkgdir}/usr/bin"
+ install -Dm755 target/release/eww "${pkgdir}/usr/bin/${_pkgname}"
mkdir -p "${pkgdir}/etc/xdg/${_pkgname}"
cp -r examples/eww-bar "${pkgdir}/etc/xdg/${_pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
-
- echo "\
-_____________________________________________________________________
-| |
-| The example config can be found in /etc/xdg/eww |
-| |
-| For better experience, please write your own config. |
-| WIKI: https://elkowar.github.io/eww/configuration.html |
-| |
-|___________________________________________________________________|"
}
diff --git a/eww.install b/eww.install
new file mode 100644
index 000000000000..3d55ba90bd60
--- /dev/null
+++ b/eww.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "\
+_____________________________________________________________________
+| |
+| The example config can be found in /etc/xdg/eww |
+| |
+| For better experience, please write your own config. |
+| WIKI: https://elkowar.github.io/eww/configuration.html |
+| |
+|___________________________________________________________________|"
+}