summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFronkles McFranko2021-01-07 11:13:26 -0800
committerFronkles McFranko2021-01-07 11:13:26 -0800
commit1469a00e97b5544949da366ecc7a26b5f09688ca (patch)
treebbb984b0794f7720e9c6c2e6db32e538d103b1b4
parent8c0152a6f466dfebc9b60a5c6d50932c6fff44f6 (diff)
downloadaur-1469a00e97b5544949da366ecc7a26b5f09688ca.tar.gz
Updated with elkowar's suggestions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d6d88da870c..a2fc79ae74dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = eww-git
pkgdesc = ElKowar's wacky widgets
- pkgver = dd3c50f
+ pkgver = 145__2021.01.03
pkgrel = 1
url = https://github.com/elkowar/eww
arch = any
- license = GPL
+ license = MIT
makedepends = cargo
makedepends = git
+ depends = gtk3
+ provides = eww
conflicts = eww
source = git+https://github.com/elkowar/eww
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8d7250d8e665..07c84586330a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Fronkles McFranko <mrelfranko@disroot.org>
pkgname=eww-git
_pkgname=eww
-pkgver=dd3c50f
+pkgver=145__2021.01.03
pkgrel=1
epoch=
pkgdesc="ElKowar's wacky widgets"
arch=('any')
url="https://github.com/elkowar/eww"
-license=('GPL')
+license=('MIT')
groups=()
-depends=()
+depends=("gtk3")
makedepends=("cargo" "git")
checkdepends=()
optdepends=()
-provides=()
+provides=("eww")
conflicts=("eww")
replaces=()
backup=()
@@ -26,24 +26,21 @@ md5sums=("SKIP")
validpgpkeys=()
pkgver() {
- cd $_pkgname
- printf "%s" "$(git describe --always --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd ${_pkgname}
+ _tag=$(git describe --tags | sed 's:^v::')
+ _commits=$(git rev-list --count HEAD)
+ _date=$(git log -1 --date=short --pretty=format:%cd)
+ printf "%s_%s_%s\n" "${_commits}" "${_tag}" "${_date}" | sed 's/-/./g'
}
build() {
- cd "$_pkgname"
- cargo build
-}
-
-check() {
- cd "$_pkgname"
- cargo check
+ cd "$_pkgname"
+ cargo build --release
}
package() {
- cd "$_pkgname"
- cargo install --path . --root "$pkgdir/usr"
+ cd "$_pkgname"
- cd "$pkgdir/usr"
- rm .crates2.json .crates.toml
+ mkdir -p "${pkgdir}/usr/bin"
+ mv target/release/eww "${pkgdir}/usr/bin"
}