summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Santini2018-08-11 18:25:49 +0200
committerAlberto Santini2018-08-11 18:25:49 +0200
commit44c184190370d6483902f301620cc17392b41820 (patch)
treee594482be8a1aab96bbe0fcb264b4a652e71dbd1
parentdf09ea22877be4430b7171050677ac177fabb39d (diff)
downloadaur-exactcolors-git.tar.gz
Simplified preparation phase (applying all patches irrespective of cplex version)
-rw-r--r--PKGBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74d0d174a301..0e34e4cea77e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,6 @@
# dir (usually under /opt/...).
_git_repo='exactcolors'
-_cpx_major=$(pacman -Q cplex | awk '{ print $2 }' | awk -F "." '{ print $1 }')
-_cpx_minor=$(pacman -Q cplex | awk '{ print $2 }' | awk -F "." '{ print $2 }' | awk -F "-" '{ print $1 }')
pkgname='exactcolors-git'
pkgdesc='A library to solve graph colouring and max-weighted stable set problems. Upstream repo by GitHub user heldstephan.'
@@ -44,10 +42,8 @@ prepare() {
cd "$srcdir/$_git_repo"
patch < "$srcdir/Makefile-cplex.patch"
- # Starting from Cplex 12.8 you need to explicitly link -ldl
- if [[ "$_cpx_major" = "12" && "$_cpx_minor" > "7" ]]; then
- patch < "$srcdir/Makefile-cplex-128.patch"
- fi
+ # Patch required for CPLEX >= 12.8 (harmless otherwise)
+ patch < "$srcdir/Makefile-cplex-128.patch"
}
build() {