summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcylgom2018-04-10 09:45:00 +0200
committercylgom2018-04-10 09:45:00 +0200
commiteffa5e655570f59f53c04eb79c515da83d6b8d33 (patch)
tree68bbb399ea3dcb874ee72ac6bcb671c1b02fe9f9
downloadaur-effa5e655570f59f53c04eb79c515da83d6b8d33.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0baab39bae6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = excalibar-git
+ pkgdesc = sharp and shiny taskbar
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/cylgom/excalibar
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = git
+ depends = libexcalibar-git
+ depends = libxcb
+ depends = cairo
+ depends = pango
+ source = git+https://github.com/cylgom/excalibar.git
+ source = git+https://github.com/benhoyt/inih.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = excalibar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7d5ae7a3c66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: cylgom <cylgom@gmail.com>
+pkgname=excalibar-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="sharp and shiny taskbar"
+arch=('i686' 'x86_64')
+url="https://github.com/cylgom/excalibar"
+license=('custom:WTFPL')
+makedepends=('git')
+depends=('libexcalibar-git' 'libxcb' 'cairo' 'pango')
+source=('git+https://github.com/cylgom/excalibar.git'
+ 'git+https://github.com/benhoyt/inih.git')
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd excalibar
+ git submodule init
+ git config submodule.inih.url $srcdir/excalibar/submodules/inih
+ git submodule update
+}
+
+build() {
+ cd excalibar/bar
+ make
+ cd ../plugins
+ make
+}
+
+package() {
+ cd excalibar/bar
+ make DESTDIR="$pkgdir" install
+ make cpconfig
+ install -D -m644 ../LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/WTFPL"
+ cd ../plugins
+ make install
+}