summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-12 15:51:50 +0800
committerzxp198210052023-09-12 15:51:50 +0800
commit2e6ece4704c3d19d8f0a584a612a5462ddcf9c97 (patch)
tree76b9cdfd694c13743df43d20887e8fa3c61424f2
parent86851f9a1934a274765bc50e7c21f2280624ea03 (diff)
downloadaur-2e6ece4704c3d19d8f0a584a612a5462ddcf9c97.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab30d780a208..3a2b525fd1b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = excel-parser-processor-bin
pkgdesc = Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed.
pkgver = 1.3.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/btargac/excel-parser-processor
arch = x86_64
license = MIT
@@ -11,7 +11,7 @@ pkgbase = excel-parser-processor-bin
provides = excel-parser-processor=1.3.1
conflicts = excel-parser-processor
source = excel-parser-processor-1.3.1.AppImage::https://github.com/btargac/excel-parser-processor/releases/download/v1.3.1/Excel-Parser-Processor-1.3.1.AppImage
- source = LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/master/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/v1.3.1/LICENSE
source = excel-parser-processor.sh
sha256sums = 90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d
sha256sums = cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7
diff --git a/PKGBUILD b/PKGBUILD
index 2c0dbe32ea37..809843561245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=excel-parser-processor-bin
_appname=Excel-Parser-Processor
pkgver=1.3.1
-pkgrel=3
+pkgrel=4
pkgdesc="Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed."
arch=('x86_64')
url="https://github.com/btargac/excel-parser-processor"
@@ -11,7 +11,7 @@ conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=('bash' 'electron13' 'hicolor-icon-theme')
source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
- "LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/master/LICENSE"
+ "LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d'
'cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7'
@@ -19,15 +19,15 @@ sha256sums=('90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d'
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
for icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024; do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${icons}/apps"
done
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file