summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-13 09:50:14 +0800
committerzxp198210052023-07-13 09:50:14 +0800
commit377f2bb152f1f9c07e7e5a3faec95a28c41d042d (patch)
treefa57a23340b2c024ab8d4361a4739240f4c7808f
downloadaur-377f2bb152f1f9c07e7e5a3faec95a28c41d042d.tar.gz
first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--excel-parser-processor.sh6
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47bc6415ac5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = excel-parser-processor-bin
+ pkgdesc = Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/btargac/excel-parser-processor
+ arch = x86_64
+ license = MIT
+ depends = electron25
+ depends = hicolor-icon-theme
+ provides = excel-parser-processor
+ conflicts = excel-parser-processor
+ source = excel-parser-processor-1.3.1.AppImage::https://github.com/btargac/excel-parser-processor/releases/download/v1.3.1/Excel-Parser-Processor-1.3.1.AppImage
+ source = LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/master/LICENSE
+ source = excel-parser-processor.sh
+ sha256sums = 90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d
+ sha256sums = cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7
+ sha256sums = 31587f1616cc148c6c22220939b5af6fae5d36884127a4bc4b6d36461c48d2db
+
+pkgname = excel-parser-processor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db139908289e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="excel-parser-processor-bin"
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed."
+arch=('x86_64')
+url="https://github.com/btargac/excel-parser-processor"
+license=('MIT')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}")
+depends=('electron25' 'hicolor-icon-theme')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/Excel-Parser-Processor-${pkgver}.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/master/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d'
+ 'cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7'
+ '31587f1616cc148c6c22220939b5af6fae5d36884127a4bc4b6d36461c48d2db')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ for icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024; do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${icons}/apps"
+ done
+ sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/excel-parser-processor.sh b/excel-parser-processor.sh
new file mode 100644
index 000000000000..9235761215b3
--- /dev/null
+++ b/excel-parser-processor.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron25 /opt/excel-parser-processor/excel-parser-processor.asar "$@"
+else
+ exec electron25 --no-sandbox /opt/excel-parser-processor/excel-parser-processor.asar "$@"
+fi \ No newline at end of file