summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-14 10:40:14 +0800
committerzxp198210052023-11-14 10:40:14 +0800
commitb56251d285d4d1cc2b9e79bcc6913a1b3b8092e5 (patch)
treec9fc216496d13d903e077d24ee418e52d4004a96
parent2e6ece4704c3d19d8f0a584a612a5462ddcf9c97 (diff)
downloadaur-b56251d285d4d1cc2b9e79bcc6913a1b3b8092e5.tar.gz
fix errors
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--excel-parser-processor.sh5
3 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a2b525fd1b7..88913b577773 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = excel-parser-processor-bin
pkgdesc = Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed.
pkgver = 1.3.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/btargac/excel-parser-processor
arch = x86_64
license = MIT
- depends = bash
+ makedepends = squashfuse
depends = electron13
depends = hicolor-icon-theme
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = excel-parser-processor=1.3.1
conflicts = excel-parser-processor
source = excel-parser-processor-1.3.1.AppImage::https://github.com/btargac/excel-parser-processor/releases/download/v1.3.1/Excel-Parser-Processor-1.3.1.AppImage
@@ -15,6 +21,6 @@ pkgbase = excel-parser-processor-bin
source = excel-parser-processor.sh
sha256sums = 90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d
sha256sums = cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7
- sha256sums = 7e64b494607f7d55ed4b330eb717bf765bf3a14da0fbf2d5234b7359ec41d00d
+ sha256sums = 50edd435b99fbbf512951cc5461694cb1818d39306336e98125be79352d7daf3
pkgname = excel-parser-processor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 809843561245..d1a36dee4092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,44 @@
pkgname=excel-parser-processor-bin
_appname=Excel-Parser-Processor
pkgver=1.3.1
-pkgrel=4
+pkgrel=5
pkgdesc="Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed."
arch=('x86_64')
url="https://github.com/btargac/excel-parser-processor"
license=('MIT')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
-depends=('bash' 'electron13' 'hicolor-icon-theme')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
+depends=(
+ 'electron13'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
"LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/v${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d'
'cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7'
- '7e64b494607f7d55ed4b330eb717bf765bf3a14da0fbf2d5234b7359ec41d00d')
-prepare() {
+ '50edd435b99fbbf512951cc5461694cb1818d39306336e98125be79352d7daf3')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
for icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024; do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${icons}/apps"
diff --git a/excel-parser-processor.sh b/excel-parser-processor.sh
index f4c093febf17..2a5a8a90b9f9 100644
--- a/excel-parser-processor.sh
+++ b/excel-parser-processor.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron13
-_ASAR="/opt/excel-parser-processor/excel-parser-processor.asar"
+APPDIR=/usr/lib/excel-parser-processor
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else