summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-03 15:48:28 +0800
committerzxp198210052023-08-03 15:48:28 +0800
commitda93c78170bb392e455136ef11f48e0e09fc8f57 (patch)
tree4c3b006dc2b90e6bc7742d5d9a62dd2a7db5a5a6
parent377f2bb152f1f9c07e7e5a3faec95a28c41d042d (diff)
downloadaur-da93c78170bb392e455136ef11f48e0e09fc8f57.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--excel-parser-processor.sh6
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47bc6415ac5f..17a2dfc1543c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = excel-parser-processor-bin
pkgdesc = Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed.
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/btargac/excel-parser-processor
arch = x86_64
license = MIT
- depends = electron25
+ depends = bash
+ depends = electron13
depends = hicolor-icon-theme
- provides = excel-parser-processor
+ provides = excel-parser-processor-1.3.1
conflicts = excel-parser-processor
source = excel-parser-processor-1.3.1.AppImage::https://github.com/btargac/excel-parser-processor/releases/download/v1.3.1/Excel-Parser-Processor-1.3.1.AppImage
source = LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/master/LICENSE
source = excel-parser-processor.sh
sha256sums = 90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d
sha256sums = cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7
- sha256sums = 31587f1616cc148c6c22220939b5af6fae5d36884127a4bc4b6d36461c48d2db
+ sha256sums = 7e64b494607f7d55ed4b330eb717bf765bf3a14da0fbf2d5234b7359ec41d00d
pkgname = excel-parser-processor-bin
diff --git a/PKGBUILD b/PKGBUILD
index db139908289e..988ca567dd89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="excel-parser-processor-bin"
+pkgname=excel-parser-processor-bin
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simply generates an array of items from the rows of an Excel file and does the repetitive tedious operations step by step recursively till every item of the array is processed."
arch=('x86_64')
url="https://github.com/btargac/excel-parser-processor"
license=('MIT')
conflicts=("${pkgname%-bin}")
-provides=("${pkgname%-bin}")
-depends=('electron25' 'hicolor-icon-theme')
+provides=("${pkgname%-bin}-${pkgver}")
+depends=('bash' 'electron13' 'hicolor-icon-theme')
source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/Excel-Parser-Processor-${pkgver}.AppImage"
"LICENSE::https://raw.githubusercontent.com/btargac/excel-parser-processor/master/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('90b96fec41aae2dffdd5a7c72dfdd8ad954b2675662a4dc4360851410aa73b5d'
'cb199ba111f4311de39df0fc7458a8573f9c62f42eb2332b4262f0e6b31a3ff7'
- '31587f1616cc148c6c22220939b5af6fae5d36884127a4bc4b6d36461c48d2db')
+ '7e64b494607f7d55ed4b330eb717bf765bf3a14da0fbf2d5234b7359ec41d00d')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/excel-parser-processor.sh b/excel-parser-processor.sh
index 9235761215b3..f4c093febf17 100644
--- a/excel-parser-processor.sh
+++ b/excel-parser-processor.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron13
+_ASAR="/opt/excel-parser-processor/excel-parser-processor.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron25 /opt/excel-parser-processor/excel-parser-processor.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron25 --no-sandbox /opt/excel-parser-processor/excel-parser-processor.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file