summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwoho2016-10-02 12:50:45 +0200
committerwoho2016-10-02 12:52:38 +0200
commit65dadf377d0a5e279f34bedfb6643c2ae138bea0 (patch)
tree1d041437dcec96a5dc80e3ff1d275b75018e3eaf
downloadaur-65dadf377d0a5e279f34bedfb6643c2ae138bea0.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb6d0547a239
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = exciting
+ pkgdesc = Full-potential all-electron density-functional-theory package implementing the families of linearized augmented planewave methods.
+ pkgver = 6.6
+ pkgrel = 1
+ url = http://exciting-code.org
+ arch = x86_64
+ makedepends = gcc
+ depends = blas
+ depends = openmp
+ depends = openmpi
+ source = http://exciting.wdfiles.com/local--files/carbon/exciting.carbon.tar.gz
+ md5sums = ef5b3e40448df12fcc09b92709780ca2
+
+pkgname = exciting
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b05a1797c79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=exciting
+pkgver=6.6
+pkgrel=1
+epoch=
+pkgdesc="Full-potential all-electron density-functional-theory package
+implementing the families of linearized augmented planewave methods."
+arch=("x86_64")
+url="http://exciting-code.org"
+license=("")
+groups=()
+depends=(blas openmp openmpi)
+makedepends=(gcc)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://exciting.wdfiles.com/local--files/carbon/exciting.carbon.tar.gz")
+noextract=()
+md5sums=("ef5b3e40448df12fcc09b92709780ca2")
+validpgpkeys=()
+
+build() {
+ cd "$srcdir/exciting"
+ cp build/platforms/make.inc.gfortran build/make.inc
+ export FCCPP="cpp"
+ make
+}
+
+package() {
+ cd "$srcdir/exciting"
+ install -d "$pkgdir/usr/bin"
+ cp -r bin/* "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/doc/exciting"
+ cp -r docs/* "$pkgdir/usr/share/doc/exciting"
+}