summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwoho2019-07-26 09:01:10 +0200
committerwoho2019-07-26 09:01:10 +0200
commita5f05fa10302357d9a78fd08bd59cc8e7b0d9dfc (patch)
tree822fffa5959bb99ed84be4c69c11af86b15ecfc0
parent65dadf377d0a5e279f34bedfb6643c2ae138bea0 (diff)
downloadaur-a5f05fa10302357d9a78fd08bd59cc8e7b0d9dfc.tar.gz
Update to version: nitrogen
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 11 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb6d0547a239..8054796b6f66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = exciting
pkgdesc = Full-potential all-electron density-functional-theory package implementing the families of linearized augmented planewave methods.
- pkgver = 6.6
+ pkgver = 7
pkgrel = 1
url = http://exciting-code.org
arch = x86_64
- makedepends = gcc
+ license = GPL
+ depends = gcc-fortran
depends = blas
depends = openmp
depends = openmpi
- source = http://exciting.wdfiles.com/local--files/carbon/exciting.carbon.tar.gz
- md5sums = ef5b3e40448df12fcc09b92709780ca2
+ source = http://exciting.wdfiles.com/local--files/nitrogen/exciting.nitrogen.tar.gz
+ md5sums = 8447e7b325ce3f00f90c7ab8781b889c
pkgname = exciting
diff --git a/PKGBUILD b/PKGBUILD
index 1b05a1797c79..773c4fa8b869 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,14 @@
pkgname=exciting
-pkgver=6.6
+pkgver=7
pkgrel=1
-epoch=
pkgdesc="Full-potential all-electron density-functional-theory package
implementing the families of linearized augmented planewave methods."
arch=("x86_64")
url="http://exciting-code.org"
-license=("")
-groups=()
-depends=(blas openmp openmpi)
-makedepends=(gcc)
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("http://exciting.wdfiles.com/local--files/carbon/exciting.carbon.tar.gz")
-noextract=()
-md5sums=("ef5b3e40448df12fcc09b92709780ca2")
-validpgpkeys=()
+license=("GPL")
+depends=(gcc-fortran blas openmp openmpi)
+source=("http://exciting.wdfiles.com/local--files/nitrogen/exciting.nitrogen.tar.gz")
+md5sums=('8447e7b325ce3f00f90c7ab8781b889c')
build() {
cd "$srcdir/exciting"
@@ -36,5 +22,6 @@ package() {
install -d "$pkgdir/usr/bin"
cp -r bin/* "$pkgdir/usr/bin"
install -d "$pkgdir/usr/share/doc/exciting"
+ chmod -R 755 docs
cp -r docs/* "$pkgdir/usr/share/doc/exciting"
}