summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeveren Redwood2022-12-16 02:48:42 +1300
committerSeveren Redwood2022-12-16 02:48:42 +1300
commitcbc70881b9e544e954a3e2c63fcbac26b46f596e (patch)
tree42b2b7ccdcb7a64b7367ebc22d191f728e16e63c
parent180dfc12f28ff8ac3661332a0eb494f22c94deaa (diff)
downloadaur-cbc70881b9e544e954a3e2c63fcbac26b46f596e.tar.gz
Update to 3.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91128d4c5446..4bd5b3a43a66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = exercism
- pkgdesc = Command line client for https://exercism.io
- pkgver = 3.0.13
+ pkgdesc = Command line tool for exercism.io
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/exercism/cli
arch = i686
@@ -8,8 +8,7 @@ pkgbase = exercism
license = MIT
makedepends = go-pie
depends = glibc
- source = https://github.com/exercism/cli/archive/v3.0.13.tar.gz
+ source = https://github.com/exercism/cli/archive/v3.1.0.tar.gz
sha256sums = ecc27f272792bc8909d14f11dd08f0d2e9bde4cc663b3769e00eab6e65328a9f
pkgname = exercism
-
diff --git a/PKGBUILD b/PKGBUILD
index 3277e884400b..3b7fd0361b85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
# Maintainer: Federico Squartini <federico.squartini at gmail dot com>
pkgname=exercism
-pkgver=3.0.13
+pkgver=3.1.0
pkgrel=1
-pkgdesc="Command line client for https://exercism.io"
+pkgdesc="Command line tool for exercism.io"
arch=("i686" "x86_64")
url="https://github.com/exercism/cli"
license=("MIT")
-depends=('glibc')
-makedepends=('go-pie')
+depends=("glibc")
+makedepends=("go-pie")
source=("https://github.com/exercism/cli/archive/v${pkgver}.tar.gz")
-sha256sums=('ecc27f272792bc8909d14f11dd08f0d2e9bde4cc663b3769e00eab6e65328a9f')
+sha256sums=('34653a6a45d49daef10db05672c9b4e36c3c30e09d57c3c0f737034d071ae4f6')
prepare() {
- export GOPATH="$srcdir"/.gopath
- mkdir -p "$GOPATH"/src/github.com/exercism
- ln -sf "$srcdir"/cli-$pkgver "$GOPATH"/src/github.com/exercism/cli
+ export GOPATH="$srcdir/.gopath"
+
+ mkdir -p "$GOPATH/src/github.com/exercism"
+ ln -sf "$srcdir/cli-$pkgver" "$GOPATH/src/github.com/exercism/cli"
}
build() {
- export GOPATH="$srcdir"/.gopath
- cd "$GOPATH"/src/github.com/exercism/cli
+ export GOPATH="$srcdir/.gopath"
+
+ cd "$GOPATH/src/github.com/exercism/cli"
go build -o out/exercism exercism/main.go
}
package(){
cd $srcdir/cli-${pkgver}
+
+ install -D out/exercism "$pkgdir/usr/bin/exercism"
+
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m644 shell/exercism_completion.bash "$pkgdir/usr/share/$pkgname/completion/exercism_completion.bash"
install -D -m644 shell/exercism_completion.zsh "$pkgdir/usr/share/$pkgname/completion/exercism_completion.zsh"
- install -D out/exercism "$pkgdir/usr/bin/exercism"
}