summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Squartini2018-10-08 11:55:22 +0200
committerFederico Squartini2018-10-08 11:55:22 +0200
commitf5b70ff781f6cfae6d50b23e57f4418074efdb22 (patch)
treef1321d73844c3b8ac5ce844178310dabc27ea72d
parented24eb4a3a22c0f006f0cf97e74d4877670d0240 (diff)
downloadaur-f5b70ff781f6cfae6d50b23e57f4418074efdb22.tar.gz
Fix: missing dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73a43ae1aa26..9748eaa14542 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = exercism
pkgdesc = Command line client for https://exercism.io
pkgver = 3.0.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/exercism/cli
arch = i686
arch = x86_64
license = MIT
- makedepends = go
+ makedepends = dep
+ makedepends = go-pie
+ depends = glibc
source = https://github.com/exercism/cli/archive/v3.0.10.tar.gz
sha256sums = 0dbb34ba3bb3571fbc75fa9f5cb0b061317589a98a1af12fe7318a2c4cdbda5b
diff --git a/PKGBUILD b/PKGBUILD
index dd16a67442ce..ae92a3bd319d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,33 @@
pkgname=exercism
pkgver=3.0.10
-pkgrel=1
+pkgrel=2
pkgdesc="Command line client for https://exercism.io"
arch=("i686" "x86_64")
url="https://github.com/exercism/cli"
license=("MIT")
-makedepends=('go')
+depends=('glibc')
+makedepends=('dep' 'go-pie')
source=("https://github.com/exercism/cli/archive/v${pkgver}.tar.gz")
sha256sums=('0dbb34ba3bb3571fbc75fa9f5cb0b061317589a98a1af12fe7318a2c4cdbda5b')
+prepare() {
+ export GOPATH="$srcdir"/.gopath
+ mkdir -p "$GOPATH"/src/github.com/exercism
+ ln -sf "$srcdir"/cli-$pkgver "$GOPATH"/src/github.com/exercism/cli
+}
+
build() {
- cd $srcdir/cli-${pkgver}
- go build -o out/exercism exercism/main.go
+ export GOPATH="$srcdir"/.gopath
+ cd "$GOPATH"/src/github.com/exercism/cli
+ dep ensure
+ go build -o out/exercism exercism/main.go
}
package(){
- cd $srcdir/cli-${pkgver}
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 shell/exercism_completion.bash "$pkgdir/usr/share/$pkgname/completion/exercism_completion.bash"
- install -D -m644 shell/exercism_completion.zsh "$pkgdir/usr/share/$pkgname/completion/exercism_completion.zsh"
- install -D out/exercism "$pkgdir/usr/bin/exercism"
+ cd $srcdir/cli-${pkgver}
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 shell/exercism_completion.bash "$pkgdir/usr/share/$pkgname/completion/exercism_completion.bash"
+ install -D -m644 shell/exercism_completion.zsh "$pkgdir/usr/share/$pkgname/completion/exercism_completion.zsh"
+ install -D out/exercism "$pkgdir/usr/bin/exercism"
}