summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Muszynski2015-07-10 11:36:50 +0200
committerMikael Muszynski2015-07-10 11:36:50 +0200
commit0abdb4207bde82190db6eb590c8160fc1897eb88 (patch)
tree8cce5ff900cfc801e8237446f1717c2d8cdfdb40
parent21ce9ea806ecc69fed4cc9b246903e62787c710c (diff)
downloadaur-0abdb4207bde82190db6eb590c8160fc1897eb88.tar.gz
Update PKGBUILD to make use of new variables
The current code makes use of a hack that was inherited from the previous maintainer. The new architecture specific variables allows for removing the if statement.
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f30f4ebe05a..7a7a86c680d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: linduxed <linduxed at gmail dot com>
+# Maintainer: linduxed <linduxed@gmail.com>
pkgname=exercism-cli
pkgver=v2.2.0
@@ -7,19 +7,12 @@ pkgdesc="Command line client for exercism.io"
arch=("i686" "x86_64")
url="https://github.com/exercism/cli"
license=("MIT")
-
-source=("https://github.com/exercism/cli/releases/download/$pkgver/exercism-linux-64bit.tgz"
- "https://raw.githubusercontent.com/exercism/cli/$pkgver/LICENSE")
-md5sums=("ddcde1e2641bc3b72c4b7fced333bf64"
- "f92fe05e2b91655399f2a8b9d24bfe41")
-
-
-if [[ $CARCH = "i686" ]]; then
- source=("https://github.com/exercism/cli/releases/download/$pkgver/exercism-linux-32bit.tgz"
- "https://raw.githubusercontent.com/exercism/cli/$pkgver/LICENSE")
- md5sums=("6e2ede3ee83c571a6b5f88a042665402"
- "f92fe05e2b91655399f2a8b9d24bfe41")
-fi
+source=("https://raw.githubusercontent.com/exercism/cli/$pkgver/LICENSE")
+md5sums=('f92fe05e2b91655399f2a8b9d24bfe41')
+source_i686=("https://github.com/exercism/cli/releases/download/$pkgver/exercism-linux-32bit.tgz")
+md5sums_i686=('6e2ede3ee83c571a6b5f88a042665402')
+source_x86_64=("https://github.com/exercism/cli/releases/download/$pkgver/exercism-linux-64bit.tgz")
+md5sums_x86_64=('ddcde1e2641bc3b72c4b7fced333bf64')
package(){
cd "$srcdir"