summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Muszynski2018-12-09 08:06:45 +0100
committerMikael Muszynski2018-12-09 08:06:45 +0100
commitc4de37209907a47a81c348f96c223937e406980d (patch)
treee7e9b57b27c5d6fa99c353614d55d5075ec35105
parent167af09c13b17aaebf7e709ef41c2531b8e96368 (diff)
downloadaur-c4de37209907a47a81c348f96c223937e406980d.tar.gz
Version the completion files
Installing with an AUR helper failed, so I'm assuming that this is a similar problem to one that happened some months ago: When an AUR helper caches source files, the files that may change need to have a version in their name.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba36e7d618a2..2f982c16632b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = exercism-cli
pkgdesc = Command line client for exercism.io
pkgver = 3.0.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/exercism/cli
arch = i686
arch = x86_64
license = MIT
source = https://raw.githubusercontent.com/exercism/cli/v3.0.11/LICENSE
- source = https://raw.githubusercontent.com/exercism/cli/v3.0.11/shell/exercism_completion.bash
- source = https://raw.githubusercontent.com/exercism/cli/v3.0.11/shell/exercism_completion.zsh
+ source = exercism_completion-v3.0.11.bash::https://raw.githubusercontent.com/exercism/cli/v3.0.11/shell/exercism_completion.bash
+ source = exercism_completion-v3.0.11.zsh::https://raw.githubusercontent.com/exercism/cli/v3.0.11/shell/exercism_completion.zsh
sha256sums = 5dd14ba854091ff4226fa6c7517b57da86acbe9b6a00c36f0c031dd4f4816c90
sha256sums = 4abb9b94262a08ede1019cbfc900d01f33123de616bb5a7c202d54ca59718590
sha256sums = 69dbcfad5c4fcc096a13e48d13a0ddc9d899ee299528081eca26ee801af7634d
diff --git a/PKGBUILD b/PKGBUILD
index 2546587a0fb1..e7cbce238d9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=exercism-cli
pkgver=3.0.11
-pkgrel=1
+pkgrel=2
pkgdesc="Command line client for exercism.io"
arch=("i686" "x86_64")
url="https://github.com/exercism/cli"
license=("MIT")
-source=("https://raw.githubusercontent.com/exercism/cli/v$pkgver/LICENSE"
- "https://raw.githubusercontent.com/exercism/cli/v$pkgver/shell/exercism_completion.bash"
- "https://raw.githubusercontent.com/exercism/cli/v$pkgver/shell/exercism_completion.zsh")
+source=("https://raw.githubusercontent.com/exercism/cli/v$pkgver/LICENSE"
+ exercism_completion-v$pkgver.bash::"https://raw.githubusercontent.com/exercism/cli/v$pkgver/shell/exercism_completion.bash"
+ exercism_completion-v$pkgver.zsh::"https://raw.githubusercontent.com/exercism/cli/v$pkgver/shell/exercism_completion.zsh")
sha256sums=('5dd14ba854091ff4226fa6c7517b57da86acbe9b6a00c36f0c031dd4f4816c90'
'4abb9b94262a08ede1019cbfc900d01f33123de616bb5a7c202d54ca59718590'
'69dbcfad5c4fcc096a13e48d13a0ddc9d899ee299528081eca26ee801af7634d')
+
source_i686=(exercism-linux-32bit-v$pkgver.tgz::"https://github.com/exercism/cli/releases/download/v$pkgver/exercism-linux-32bit.tgz")
sha256sums_i686=('7c22143b358e6e4370f6f1d0721f7167d8221bd0d74addd9fb94c9a4755f51a8')
source_x86_64=(exercism-linux-64bit-v$pkgver.tgz::"https://github.com/exercism/cli/releases/download/v$pkgver/exercism-linux-64bit.tgz")
@@ -22,7 +23,7 @@ sha256sums_x86_64=('bf0a55abc27cbdcfcc1cba4336eafdec3486b2434b96017b75d54ec8fc7a
package(){
cd "$srcdir"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 exercism_completion.bash "$pkgdir/usr/share/$pkgname/completion/exercism_completion.bash"
- install -D -m644 exercism_completion.zsh "$pkgdir/usr/share/$pkgname/completion/exercism_completion.zsh"
+ install -D -m644 exercism_completion-v$pkgver.bash "$pkgdir/usr/share/$pkgname/completion/exercism_completion.bash"
+ install -D -m644 exercism_completion-v$pkgver.zsh "$pkgdir/usr/share/$pkgname/completion/exercism_completion.zsh"
install -D exercism "$pkgdir/usr/bin/exercism"
}