summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2018-12-31 14:32:10 +0100
committerfrederik2018-12-31 14:32:10 +0100
commit0a8de6e5ef441a5205bfecf21403b1fc480b865f (patch)
treebad9b5b342680f318f49cb39583b50c3c0957871
parentc2f379f596dc200a904d76d72a1e660c3015ec37 (diff)
downloadaur-0a8de6e5ef441a5205bfecf21403b1fc480b865f.tar.gz
reflect upstream changes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b05cafd7a26d..c349c26494b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = exfat-utils-nofuse
pkgdesc = Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/relan/exfat
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 325a0fb22865..15a899189a6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=exfat-utils-nofuse
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)'
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
url='https://github.com/relan/exfat'
@@ -16,18 +16,21 @@ replaces=('exfat-utils')
source=(exfat-${pkgver}.tar.gz::https://github.com/relan/exfat/archive/v${pkgver}.tar.gz)
sha512sums=('fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8ae5e891c46195be53d2a10d62444e2fa1bb3fa3de59c2c3411c6dac363b488')
-build() {
+prepare() {
cd exfat-${pkgver}
-
# exclude fuse directory
sed -i 's/fuse label mkfs/label mkfs/' Makefile.am
+ autoreconf -fiv
+}
- autoreconf -i
+build() {
+ cd exfat-${pkgver}
./configure --prefix=/usr --sbindir=/usr/bin
- make CCFLAGS="${CFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
+ make CCFLAGS="${CFLAGS} ${CPPFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
}
package() {
cd exfat-${pkgver}
make DESTDIR="${pkgdir}" install
+ install -Dm 644 */*.8 -t "${pkgdir}/usr/share/man/man8"
}