summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2019-10-31 13:12:33 +0100
committerfrederik2019-10-31 13:16:45 +0100
commit7dc87ee685ff8066cb29e4128f91781194a53b18 (patch)
tree65d33d7a3634de1e6a7900d8059d8e9fde789e54
parent96f7c00d239352148ec7b0e2c7e1e7fce643680a (diff)
downloadaur-7dc87ee685ff8066cb29e4128f91781194a53b18.tar.gz
PKGBUILD review by svenstaro
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
-rw-r--r--PKGBUILD-namcap.log0
-rw-r--r--nofuse.patch26
4 files changed, 35 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76994da5d1db..1573f6b299b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,9 @@ pkgbase = exfat-utils-nofuse
conflicts = fuse-exfat
conflicts = exfat-utils
source = exfat-1.3.0.tar.gz::https://github.com/relan/exfat/archive/v1.3.0.tar.gz
+ source = nofuse.patch
sha512sums = fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8ae5e891c46195be53d2a10d62444e2fa1bb3fa3de59c2c3411c6dac363b488
+ sha512sums = 0230949d9d8775e88a08adc638f49de30aac53963528db2141f5fea5f41a89f08869bace29e121c99bb7af0ba0bb60b671f437950d26024533abaacb49ec78ae
pkgname = exfat-utils-nofuse
diff --git a/PKGBUILD b/PKGBUILD
index b80b77a5c999..d6470a5a9f12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,15 @@ license=('GPL2')
depends=('glibc')
provides=('exfat-utils')
conflicts=('fuse-exfat' 'exfat-utils' )
-source=(exfat-${pkgver}.tar.gz::https://github.com/relan/exfat/archive/v${pkgver}.tar.gz)
-sha512sums=('fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8ae5e891c46195be53d2a10d62444e2fa1bb3fa3de59c2c3411c6dac363b488')
+source=(exfat-${pkgver}.tar.gz::https://github.com/relan/exfat/archive/v${pkgver}.tar.gz
+ nofuse.patch)
+sha512sums=('fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8ae5e891c46195be53d2a10d62444e2fa1bb3fa3de59c2c3411c6dac363b488'
+ '0230949d9d8775e88a08adc638f49de30aac53963528db2141f5fea5f41a89f08869bace29e121c99bb7af0ba0bb60b671f437950d26024533abaacb49ec78ae')
prepare() {
cd exfat-${pkgver}
- # build without fuse
- sed -i 's/fuse label mkfs/label mkfs/' Makefile.am
- sed -i '/fuse/d' configure.ac
+ # build without fuse support
+ patch -p0 < ${srcdir}/nofuse.patch
}
build() {
@@ -31,5 +32,5 @@ build() {
package() {
cd exfat-${pkgver}
make DESTDIR="${pkgdir}" install
- install -Dm 644 */*.8 -t "${pkgdir}/usr/share/man/man8"
+ install -Dm644 */*.8 -t "${pkgdir}"/usr/share/man/man8
}
diff --git a/PKGBUILD-namcap.log b/PKGBUILD-namcap.log
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/PKGBUILD-namcap.log
diff --git a/nofuse.patch b/nofuse.patch
new file mode 100644
index 000000000000..f8dd8430eb09
--- /dev/null
+++ b/nofuse.patch
@@ -0,0 +1,26 @@
+diff --git configure.ac configure.ac
+--- configure.ac 2018-09-15 07:03:24.000000000 +0200
++++ configure.ac 2019-10-28 18:02:19.792588993 +0100
+@@ -37,13 +37,11 @@
+ AC_DEFINE([USE_UBLIO], [1],
+ [Define if block devices are not supported.])
+ ], [:])
+-PKG_CHECK_MODULES([FUSE], [fuse])
+ AC_CONFIG_HEADERS([libexfat/config.h])
+ AC_CONFIG_FILES([
+ libexfat/Makefile
+ dump/Makefile
+ fsck/Makefile
+- fuse/Makefile
+ label/Makefile
+ mkfs/Makefile
+ Makefile])
+diff --git Makefile.am Makefile.am
+--- Makefile.am 2018-09-15 07:03:24.000000000 +0200
++++ Makefile.am 2019-10-28 18:02:19.785922319 +0100
+@@ -20,4 +20,4 @@
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ #
+
+-SUBDIRS = libexfat dump fsck fuse label mkfs
++SUBDIRS = libexfat dump fsck label mkfs