summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-01-12 23:36:14 +0100
committerfrederik2017-01-12 23:36:14 +0100
commitd78e0cc95e0fa5a54c1780562b1b2156f37e235a (patch)
tree37773ed4c9587a4dcd76481f888bb7fd01b42357
downloadaur-d78e0cc95e0fa5a54c1780562b1b2156f37e235a.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e41af0329e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Jan 12 22:35:58 UTC 2017
+pkgbase = exfat-utils-nofuse
+ pkgdesc = Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/relan/exfat
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ provides = exfat-utils
+ conflicts = fuse-exfat
+ conflicts = exfat-utils
+ replaces = exfat-utils
+ source = exfat-1.2.5.tar.gz::https://github.com/relan/exfat/archive/v1.2.5.tar.gz
+ sha512sums = 37545ed3c89c17d16ae235592aaf48748c49b13b127a2cad3b6bc90632a5ecf00023393197a61bbaf7ad7715fa5d83a3b1cb8faa0d8cdc527919fa717b2ee9bf
+
+pkgname = exfat-utils-nofuse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcbdf07ecf01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+# Contributor: rtfreedman <rob<d_t>til<d_t>freedman<a@T>g*a*l<d_t>com>
+
+pkgname=exfat-utils-nofuse
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)"
+arch=('i686' 'x86_64')
+url='https://github.com/relan/exfat'
+license=('GPL2')
+depends=('glibc')
+provides=('exfat-utils')
+conflicts=('fuse-exfat' 'exfat-utils' )
+replaces=('exfat-utils')
+source=(exfat-${pkgver}.tar.gz::https://github.com/relan/exfat/archive/v${pkgver}.tar.gz)
+sha512sums=('37545ed3c89c17d16ae235592aaf48748c49b13b127a2cad3b6bc90632a5ecf00023393197a61bbaf7ad7715fa5d83a3b1cb8faa0d8cdc527919fa717b2ee9bf')
+
+build() {
+ cd exfat-${pkgver}
+
+ # exclude fuse directory
+ sed -i 's/fuse label mkfs/label mkfs/' Makefile.am
+
+ autoreconf -i
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make CCFLAGS="${CFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
+}
+
+package() {
+ cd exfat-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}