summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2019-03-13 22:31:48 +0100
committerfrederik2019-03-13 22:31:48 +0100
commiteccefdd78d19b8e11f596ddb39606d4cf73bdba2 (patch)
treeb0883182077a55f154007ec7a2e3d376670b9fce
parent0a8de6e5ef441a5205bfecf21403b1fc480b865f (diff)
downloadaur-eccefdd78d19b8e11f596ddb39606d4cf73bdba2.tar.gz
remove entire fuse dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c349c26494b7..d42225705249 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = exfat-utils-nofuse
pkgdesc = Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/relan/exfat
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = exfat-utils-nofuse
arch = arm
arch = aarch64
license = GPL2
- makedepends = fuse
depends = glibc
provides = exfat-utils
conflicts = fuse-exfat
diff --git a/PKGBUILD b/PKGBUILD
index 15a899189a6f..e1043acea9d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,12 @@
pkgname=exfat-utils-nofuse
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc='Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)'
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
url='https://github.com/relan/exfat'
license=('GPL2')
depends=('glibc')
-makedepends=('fuse')
provides=('exfat-utils')
conflicts=('fuse-exfat' 'exfat-utils' )
replaces=('exfat-utils')
@@ -18,13 +17,14 @@ sha512sums=('fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8a
prepare() {
cd exfat-${pkgver}
- # exclude fuse directory
+ # build without fuse
sed -i 's/fuse label mkfs/label mkfs/' Makefile.am
- autoreconf -fiv
+ sed -i '/fuse/d' configure.ac
}
build() {
cd exfat-${pkgver}
+ autoreconf -fiv
./configure --prefix=/usr --sbindir=/usr/bin
make CCFLAGS="${CFLAGS} ${CPPFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
}