summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-03-25 01:09:34 +0800
committerChocobo12021-03-25 01:11:26 +0800
commit111e5209cf2339c9d5ba9fc045110cc45e67488e (patch)
treeba5cf18ae015c4d15de8435f8057329f0d28f491
downloadaur-111e5209cf2339c9d5ba9fc045110cc45e67488e.tar.gz
newpkg: exif-git 0.6.22.r28.g6ec97f8-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b1d62c15d36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = exif-git
+ pkgdesc = Command-line utility to show EXIF information
+ pkgver = 0.6.22.r28.g6ec97f8
+ pkgrel = 1
+ url = https://libexif.github.io/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ depends = libexif
+ depends = popt
+ provides = exif
+ conflicts = exif
+ source = git+https://github.com/libexif/exif.git
+ sha256sums = SKIP
+
+pkgname = exif-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8d3977b98c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=exif-git
+pkgver=0.6.22.r28.g6ec97f8
+pkgrel=1
+pkgdesc="Command-line utility to show EXIF information"
+arch=('i686' 'x86_64')
+url="https://libexif.github.io/"
+license=('LGPL')
+depends=('glibc' 'libexif' 'popt')
+makedepends=('git')
+provides=('exif')
+conflicts=('exif')
+source=("git+https://github.com/libexif/exif.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "exif"
+
+ git describe --long --tags | sed 's/^exif-//;s/-release//;s/\([^-]*-g\)/r\1/;s/[-_]/./g'
+}
+
+build() {
+ cd "exif"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "exif"
+
+ make check
+}
+
+package() {
+ cd "exif"
+
+ make DESTDIR="$pkgdir" install
+}