summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarkfish Tech2024-04-08 02:08:36 +1000
committerDarkfish Tech2024-04-08 02:08:36 +1000
commita95319b4718701dd948077e798f8101d7784e8bf (patch)
tree341fce75fa6dc9b99163054b25f17a782dc66466
parentada65ff5103355a90a3b9a26853daa2f6cb33759 (diff)
downloadaur-exo-git.tar.gz
Cleanup PKGBUILD and dependencies per upstream
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c65bb347af4a..d4d26582295f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = exo-git
pkgdesc = Extensions to Xfce originally developed by os-cillation.
- pkgver = 0.12.11+68+ga978d108
+ pkgver = 4.19.0+11+g66004671
pkgrel = 1
epoch = 1
url = https://gitlab.xfce.org/xfce/exo/
@@ -8,21 +8,14 @@ pkgbase = exo-git
arch = x86_64
groups = xfce4-git
license = GPL2
- license = LGPL2.1
- makedepends = xfce4-dev-tools
+ license = LGPL
makedepends = git
- makedepends = pkgconfig
- makedepends = libnotify
- makedepends = perl-uri
- depends = hicolor-icon-theme
+ makedepends = xfce4-dev-tools
depends = libxfce4ui
- optdepends = libnotify: enables notification support
- optdepends = perl: enables mail-compose helper script
- provides = exo=0.12.11+68+ga978d108
+ provides = exo=4.19.0
conflicts = exo
options = !libtool
source = exo::git+https://gitlab.xfce.org/xfce/exo.git
md5sums = SKIP
pkgname = exo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bc0b0e034e59..38826147f270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,18 +8,17 @@
_pkgname=exo
pkgname=${_pkgname}-git
-pkgver=0.12.11+68+ga978d108
+pkgver=4.19.0+11+g66004671
pkgrel=1
pkgdesc="Extensions to Xfce originally developed by os-cillation."
arch=('i686' 'x86_64')
-license=('GPL2' 'LGPL2.1')
+license=('GPL2' 'LGPL')
url="https://gitlab.xfce.org/xfce/exo/"
groups=('xfce4-git')
-provides=("exo=${pkgver}")
-depends=('hicolor-icon-theme' 'libxfce4ui')
-makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri')
-optdepends=('libnotify: enables notification support'
- 'perl: enables mail-compose helper script')
+#provides=("exo=${pkgver}")
+provides=("${_pkgname}=${pkgver%%+*}")
+depends=('libxfce4ui')
+makedepends=('git' 'xfce4-dev-tools')
conflicts=('exo')
source=("${_pkgname}::git+https://gitlab.xfce.org/xfce/${_pkgname}.git")
options=('!libtool')
@@ -36,6 +35,7 @@ pkgver(){
build() {
cd "${_pkgname}"
+ #./autogen.sh --help=recursive
./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
@@ -43,7 +43,8 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-gtk-doc \
- --disable-debug
+ --enable-debug=minimum \
+ --enable-maintainer-mode
make
}