summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel O'Neil2018-08-17 16:18:57 -0400
committerMarcel O'Neil2018-08-17 16:18:57 -0400
commit4aaa59d8583ba63631621be48d7de902d4b207e5 (patch)
treea2e15655ff16d76ee934a238cbeae9b9ec45a7c9
parentb1ed5223a4036c6cf1527e65c2a754cb74bdb64f (diff)
downloadaur-4aaa59d8583ba63631621be48d7de902d4b207e5.tar.gz
1.58.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 11 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ccd1c5692a5..cb38ec1db6f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,21 @@
pkgbase = exodus
pkgdesc = All-in-one app to secure, manage and exchange blockchain assets
- pkgver = 1.57.0
- pkgrel = 2
+ pkgver = 1.58.0
+ pkgrel = 1
url = https://exodus.io
arch = x86_64
license = custom:"Copyright © 2017 Exodus"
- makedepends = patchelf
depends = gconf
depends = gtk2
depends = nss
depends = libxss
- noextract = glibc-2.27-3-x86_64.pkg.tar.xz
- options = !strip
- options = staticlibs
- source = https://exodusbin.azureedge.net/releases/exodus-linux-x64-1.57.0.zip
+ depends = glibc>=2.28-4
+ source = https://exodusbin.azureedge.net/releases/exodus-linux-x64-1.58.0.zip
source = http://marceloneil.com/exodus-icons/icons.zip
source = exodus.desktop
- source = https://archive.archlinux.org/packages/g/glibc/glibc-2.27-3-x86_64.pkg.tar.xz
- sha256sums = fc4e439274f8ff93e893c0c878e20b0f04f97d5b4ec668814549daad0b8ecf93
+ sha256sums = ec71068851075b535764bfb66ebb4445c043f5ff3d8517b1874aad2db0dc36ae
sha256sums = 5f3da3a79fea80477f38e698a2ea1723320f4b3fc90bf7d615dab12af0d34c1a
sha256sums = 04676d81272a35a91150a7eec4640e69ca50f2e479d29fad8be90160ee74122c
- sha256sums = a9e1b18d7f613be660556dbd6883781e88a0f5113230147e230d3e2f268792dc
pkgname = exodus
diff --git a/PKGBUILD b/PKGBUILD
index 6516fa0b1981..bb3dae8243c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,19 @@
# Maintainer: Marcel O'Neil <marcel@marceloneil.com>
pkgname=exodus
-pkgver=1.57.0
-pkgrel=2
+pkgver=1.58.0
+pkgrel=1
pkgdesc="All-in-one app to secure, manage and exchange blockchain assets"
arch=('x86_64')
url="https://exodus.io"
license=('custom:"Copyright © 2017 Exodus"')
-depends=('gconf' 'gtk2' 'nss' 'libxss')
-makedepends=(patchelf)
-options=("!strip" "staticlibs")
-noextract=("glibc-2.27-3-x86_64.pkg.tar.xz")
+depends=('gconf' 'gtk2' 'nss' 'libxss' 'glibc>=2.28-4')
source=("https://exodusbin.azureedge.net/releases/exodus-linux-x64-${pkgver}.zip"
"http://marceloneil.com/exodus-icons/icons.zip"
- "${pkgname}.desktop"
- "https://archive.archlinux.org/packages/g/glibc/glibc-2.27-3-x86_64.pkg.tar.xz")
-sha256sums=('fc4e439274f8ff93e893c0c878e20b0f04f97d5b4ec668814549daad0b8ecf93'
+ "${pkgname}.desktop")
+sha256sums=('ec71068851075b535764bfb66ebb4445c043f5ff3d8517b1874aad2db0dc36ae'
'5f3da3a79fea80477f38e698a2ea1723320f4b3fc90bf7d615dab12af0d34c1a'
- '04676d81272a35a91150a7eec4640e69ca50f2e479d29fad8be90160ee74122c'
- 'a9e1b18d7f613be660556dbd6883781e88a0f5113230147e230d3e2f268792dc')
+ '04676d81272a35a91150a7eec4640e69ca50f2e479d29fad8be90160ee74122c')
package() {
cd $srcdir/Exodus-linux-x64
@@ -37,15 +32,4 @@ package() {
$pkgdir/usr/share/icons/hicolor/$i/apps/exodus.png
done
chmod -R ugo+rX $pkgdir/opt
-
- # From https://aur.archlinux.org/cgit/aur.git/commit/?h=visual-studio-code-bin&id=e025a0af8d422d5f0d1e7ccd31e340473acb5512
- cd $srcdir
- _ldir="/opt/$pkgname"
- _pdir="$pkgdir/$_ldir"
- _pexe="$_pdir/Exodus"
- mkdir -p "$_pdir/glibc"
- tar -xJC "$_pdir/glibc" -f "glibc-2.27-3-x86_64.pkg.tar.xz"
- rm "$_pdir/glibc/"{.BUILDINFO,.INSTALL,.MTREE,.PKGINFO}
- patchelf --set-interpreter "$_ldir/glibc/usr/lib/ld-linux-x86-64.so.2" "$_pexe"
- patchelf --set-rpath "$_ldir:$_ldir/glibc/usr/lib" "$_pexe"
}